Add ~x64-macos to all package KEYWORDS.
[wtk-prefix-overlay.git] / dev-python / yolk / yolk-0.4.1.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 # API of python.eclass in EAPI > 3 not established (see python.eclass)'
6 EAPI="3"
7
8 # HACK: PYTHON_DEPEND and RESTRICT_PYTHON_ABIS currently hardcoded.
9 PYTHON_DEPEND="2"
10 SUPPORT_PYTHON_ABIS="1"
11 RESTRICT_PYTHON_ABIS="3.*"
12
13 PYTHON_MODNAME="yolk"
14
15 inherit distutils
16
17 DESCRIPTION="Command-line tool querying PyPI and Python packages installed on your system."
18 HOMEPAGE="http://tools.assembla.com/yolk/"
19 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
20 LICENSE="GPL-2"
21 KEYWORDS="~amd64 ~x64-macos ~x86"
22 SLOT="0"
23 IUSE="test doc examples"
24 DEPEND="dev-python/setuptools
25         test? ( dev-python/nose )"
26 RDEPEND="dev-python/setuptools
27         dev-python/yolk-portage"
28
29 src_install() {
30         distutils_src_install
31         if use doc; then
32                 dodoc "${S}"/docs/*
33         fi
34         if use examples; then
35                 insinto /usr/share/doc/"${PF}"/examples
36                 doins -r "${S}"/examples/*
37         fi
38 }
39
40 src_test() {
41         PYTHONPATH=. "${python}" setup.py nosetests || die "tests failed"
42 }