Import yolk-0.4.1 from standard Portage tree.
[wtk-prefix-overlay.git] / dev-python / yolk / yolk-0.4.1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6 PYTHON_DEPEND="2"
7 SUPPORT_PYTHON_ABIS="1"
8 RESTRICT_PYTHON_ABIS="3.*"
9
10 inherit distutils
11
12 DESCRIPTION="Tool and library for querying PyPI and locally installed Python packages"
13 HOMEPAGE="http://pypi.python.org/pypi/yolk"
14 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="examples"
20
21 DEPEND="dev-python/setuptools"
22 RDEPEND="dev-python/yolk-portage"
23
24 src_install() {
25         distutils_src_install
26
27         if use examples; then
28                 docinto examples/plugins
29                 dodoc examples/plugins/*
30                 docinto examples/plugins/yolk_portage
31                 dodoc examples/plugins/yolk_portage/*
32                 docinto examples/plugins/yolk_pkg_manager
33                 dodoc examples/plugins/yolk_pkg_manager/*
34                 prepalldocs
35         fi
36 }