Add ~x64-macos to all package KEYWORDS.
[wtk-prefix-overlay.git] / dev-python / yolk-portage / yolk-portage-0.1.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 PYTHON_DEPEND="*:2.6"
8 SUPPORT_PYTHON_ABIS="1"
9 RESTRICT_PYTHON_ABIS="3.*"
10
11 inherit distutils
12
13 DESCRIPTION="Plugin to show which Python packages were installed via Gentoo's Portage system."
14 HOMEPAGE="http://tools.assembla.com/yolk/"
15 SRC_URI="http://pypi.python.org/packages/source/y/yolk-portage/${P}.tar.gz"
16 LICENSE="GPL-2"
17 KEYWORDS="~x64-macos ~x86"
18 SLOT="0"
19 IUSE="test"
20 DEPEND="dev-python/setuptools
21         test? ( dev-python/nose )"
22
23 src_test() {
24         PYTHONPATH=. "${python}" setup.py nosetests || die "tests failed"
25 }
26