Add ASTranslate ebuild (much like the ASDictionary ebuild).
[wtk-prefix-overlay.git] / dev-python / astranslate / astranslate-9999.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 PYTHON_DEPEND="*"
8 SUPPORT_PYTHON_ABIS="1"
9
10 inherit subversion python
11
12 MY_PN="ASTranslate"
13
14 DESCRIPTION="Convert AppleScript into its appscript equivalent"
15 HOMEPAGE="http://appscript.sourceforge.net"
16 SRC_URI=""
17 ESVN_REPO_URI="https://appscript.svn.sourceforge.net/svnroot/appscript/${MY_PN}/trunk/src"
18 LICENSE="public-domain"
19 KEYWORDS="~x64-macos ~x86"
20 SLOT="0"
21 IUSE=""
22
23 DEPEND=">=dev-python/setuptools-0.6.14
24         >=dev-python/appscript-0.22.0
25         >=dev-python/osaterminology-0.14.6
26         >=virtual/pyobjc-1.4
27         >=dev-python/py2app-0.5.2"
28 RDEPEND="$DEPEND"
29
30 src_compile() {
31         python setup.py py2app
32 }
33
34 src_install() {
35   APP_DIR="${ED}Applications"
36         mkdir -p "${APP_DIR}"
37         cp -rp "dist/${MY_PN}.app" "${APP_DIR}"
38 }