Remove `extra_path` option from appscript and dependencies setup.py.
[wtk-prefix-overlay.git] / dev-python / appscript / appscript-1.0.0.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 PYTHON_DEPEND="*"
8 SUPPORT_PYTHON_ABIS="1"
9
10 inherit distutils
11
12 DESCRIPTION="Control AppleScriptable applications from Python."
13 HOMEPAGE="http://appscript.sourceforge.net"
14 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
15 LICENSE="public-domain"
16 KEYWORDS="~x64-macos ~x86"
17 SLOT="0"
18 IUSE=""
19 DEPEND="dev-python/setuptools"
20
21 src_prepare() {
22         cd "${S}"
23         sed -i 's/^[[:space:]]*extra_path[[:space:]]*=.*//' setup.py
24         distutils_src_prepare
25 }