gnome-base/dconf-editor: bump to 3.34.4
authorMart Raudsepp <leio@gentoo.org>
Sun, 22 Mar 2020 14:53:22 +0000 (16:53 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sun, 22 Mar 2020 15:21:29 +0000 (17:21 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
gnome-base/dconf-editor/Manifest
gnome-base/dconf-editor/dconf-editor-3.34.4.ebuild [new file with mode: 0644]

index 7c3218d61487a89b7c994445f907e4c9941027f3..b10fd85e5a47f57935367d998b93e00ccf9a7578 100644 (file)
@@ -1 +1,2 @@
 DIST dconf-editor-3.34.2.tar.xz 560308 BLAKE2B 9172a4dd77765d067228c6652b004bd6811c71a83bb4191a71ef70181a5e0aa1c3bca6d655c76eb032793eb5c39364ece23337fa86d1a6e31e59391a3554933e SHA512 6c2d89d2d62a768b669ca49e0298bddf4f4151358f0fc0314431c7f926df2323ac3b61540f2a3c95c7b5a88e4e2f08dae4d00f601506c9610a0edee4b00ba499
+DIST dconf-editor-3.34.4.tar.xz 568388 BLAKE2B 9b67ab82e01b551b898e7fd19a8990bf7f2acbf4dd9f80ad58226f82743fe96e856c0a0647be854141f25a3339d062da8eaba3c6b2fcdc6fe99718d25ce6b6b7 SHA512 8ac9be21838d66b57bcf8bcf14b7835398ebe2478bd851f8299c43427ccc7953f545dc0fa8f10dc2c5e837b9dcec4f503bc25ffd8c633066f5326873e3c4ef3f
diff --git a/gnome-base/dconf-editor/dconf-editor-3.34.4.ebuild b/gnome-base/dconf-editor/dconf-editor-3.34.4.ebuild
new file mode 100644 (file)
index 0000000..bda15a6
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.40"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Graphical tool for editing the dconf configuration database"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/dconf-editor"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-linux"
+
+RDEPEND="
+       >=gnome-base/dconf-0.26.1
+       >=dev-libs/glib-2.55.1:2
+       >=x11-libs/gtk+-3.22.27:3
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       $(vala_depend)
+       dev-libs/libxml2:2
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+"
+
+src_prepare() {
+       vala_src_prepare
+       xdg_src_prepare
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_schemas_update
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_schemas_update
+}