gnome-base/dconf-editor: bump to 3.34.4
[gentoo.git] / gnome-base / dconf-editor / dconf-editor-3.34.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 VALA_MIN_API_VERSION="0.40"
6
7 inherit gnome.org gnome2-utils meson vala xdg
8
9 DESCRIPTION="Graphical tool for editing the dconf configuration database"
10 HOMEPAGE="https://gitlab.gnome.org/GNOME/dconf-editor"
11
12 LICENSE="GPL-3+"
13 SLOT="0"
14
15 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-linux"
16
17 RDEPEND="
18         >=gnome-base/dconf-0.26.1
19         >=dev-libs/glib-2.55.1:2
20         >=x11-libs/gtk+-3.22.27:3
21 "
22 DEPEND="${RDEPEND}"
23 BDEPEND="
24         $(vala_depend)
25         dev-libs/libxml2:2
26         >=sys-devel/gettext-0.19.8
27         virtual/pkgconfig
28 "
29
30 src_prepare() {
31         vala_src_prepare
32         xdg_src_prepare
33 }
34
35 pkg_postinst() {
36         xdg_pkg_postinst
37         gnome2_schemas_update
38 }
39
40 pkg_postrm() {
41         xdg_pkg_postrm
42         gnome2_schemas_update
43 }