*/*: Switch games proj to cmake.eclass
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 3 Jan 2020 19:34:09 +0000 (20:34 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 4 Jan 2020 09:37:21 +0000 (10:37 +0100)
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
30 files changed:
dev-games/openscenegraph-qt/openscenegraph-qt-3.5.7.ebuild
dev-games/openscenegraph/openscenegraph-3.6.4.ebuild
dev-games/physfs/physfs-3.0.2.ebuild
dev-games/physfs/physfs-9999.ebuild
games-action/abuse/abuse-0.9_p20181213-r1.ebuild
games-action/lugaru/lugaru-20151204-r1.ebuild
games-action/supertuxkart/supertuxkart-1.0.ebuild
games-action/violetland/violetland-0.5.ebuild
games-arcade/commandergenius/commandergenius-2.3.3.ebuild
games-arcade/slimevolley/slimevolley-2.4.2-r1.ebuild
games-arcade/supertux/supertux-0.6.0.ebuild
games-arcade/supertux/supertux-0.6.1.1.ebuild
games-board/cockatrice/cockatrice-20190304-r1.ebuild
games-emulation/hatari/hatari-2.2.1.ebuild
games-emulation/vbam/vbam-2.1.4.ebuild
games-emulation/vbam/vbam-9999.ebuild
games-engines/openmw/openmw-0.45.0.ebuild
games-fps/doomsday/doomsday-2.1.1.ebuild
games-puzzle/pingus/pingus-9999.ebuild
games-roguelike/moria/moria-5.7.10.ebuild
games-strategy/hedgewars/hedgewars-1.0.0-r1.ebuild
games-strategy/wesnoth/wesnoth-1.14.7.ebuild
games-strategy/wesnoth/wesnoth-1.14.9.ebuild
games-strategy/wesnoth/wesnoth-1.15.2.ebuild
games-strategy/widelands/widelands-0.20.ebuild
games-strategy/widelands/widelands-0.20_rc1.ebuild
games-util/lgogdownloader/lgogdownloader-3.5.ebuild
games-util/lgogdownloader/lgogdownloader-9999.ebuild
games-util/qjoypad/qjoypad-4.3.1.ebuild
media-libs/libopenglrecorder/libopenglrecorder-0.1.0.ebuild

index 1a1be79e4194e860b488bab4c1338dd052d40d5d..fd7f48f62dbc418572d88c57a8cc1e839c648170 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 MY_PN="osgQt"
 MY_P=${MY_PN}-${PV}
-inherit cmake-utils
+inherit cmake
 
 DESCRIPTION="Qt support for OpenSceneGraph"
 HOMEPAGE="http://www.openscenegraph.org/"
@@ -41,8 +41,8 @@ src_configure() {
                -DDYNAMIC_OPENSCENEGRAPH=ON
                -DDESIRED_QT_VERSION=5
                -DBUILD_OSG_EXAMPLES=$(usex examples)
-               $(cmake-utils_use_find_package webkit Qt5WebKitWidgets)
+               $(cmake_use_find_package webkit Qt5WebKitWidgets)
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
index 1f0f59ca8e4f2b4ffb5352667ea02cfa76b842b5..1e0f1b579dc26fe1be78068b4128e7a4a20e0d4d 100644 (file)
@@ -6,7 +6,7 @@ EAPI=7
 MY_PN="OpenSceneGraph"
 MY_P=${MY_PN}-${PV}
 WX_GTK_VER="3.0"
-inherit cmake-utils flag-o-matic wxwidgets
+inherit cmake flag-o-matic wxwidgets
 
 DESCRIPTION="Open source high performance 3D graphics toolkit"
 HOMEPAGE="http://www.openscenegraph.org/"
@@ -101,51 +101,51 @@ src_configure() {
                -DOSG_ENVVAR_SUPPORTED=ON
                -DOSG_PROVIDE_READFILE=ON
                -DOSG_USE_LOCAL_LUA_SOURCE=OFF
-               $(cmake-utils_use_find_package asio Asio)
-               $(cmake-utils_use_find_package curl CURL)
+               $(cmake_use_find_package asio Asio)
+               $(cmake_use_find_package curl CURL)
                -DBUILD_DOCUMENTATION=$(usex doc)
-               $(cmake-utils_use_find_package dicom DCMTK)
-               $(cmake-utils_use_find_package egl EGL)
+               $(cmake_use_find_package dicom DCMTK)
+               $(cmake_use_find_package egl EGL)
                -DBUILD_OSG_EXAMPLES=$(usex examples)
-               $(cmake-utils_use_find_package ffmpeg FFmpeg)
-               $(cmake-utils_use_find_package gdal GDAL)
-               $(cmake-utils_use_find_package gif GIFLIB)
-               $(cmake-utils_use_find_package gstreamer GLIB)
-               $(cmake-utils_use_find_package gstreamer GStreamer)
-               $(cmake-utils_use_find_package gtk GtkGl)
-               $(cmake-utils_use_find_package jpeg JPEG)
+               $(cmake_use_find_package ffmpeg FFmpeg)
+               $(cmake_use_find_package gdal GDAL)
+               $(cmake_use_find_package gif GIFLIB)
+               $(cmake_use_find_package gstreamer GLIB)
+               $(cmake_use_find_package gstreamer GStreamer)
+               $(cmake_use_find_package gtk GtkGl)
+               $(cmake_use_find_package jpeg JPEG)
                -DCMAKE_DISABLE_FIND_PACKAGE_Jasper=ON
-               $(cmake-utils_use_find_package las LIBLAS)
-               $(cmake-utils_use_find_package lua Lua51)
+               $(cmake_use_find_package las LIBLAS)
+               $(cmake_use_find_package lua Lua51)
                -DCMAKE_DISABLE_FIND_PACKAGE_Lua52=ON
                -DCMAKE_DISABLE_FIND_PACKAGE_OpenCascade=ON
-               $(cmake-utils_use_find_package openexr OpenEXR)
-               $(cmake-utils_use_find_package openinventor Inventor)
+               $(cmake_use_find_package openexr OpenEXR)
+               $(cmake_use_find_package openinventor Inventor)
                -DBUILD_OSG_APPLICATIONS=$(usex osgapps)
-               $(cmake-utils_use_find_package pdf Poppler-glib)
-               $(cmake-utils_use_find_package png PNG)
-               $(cmake-utils_use_find_package sdl SDL)
-               $(cmake-utils_use_find_package sdl2 SDL2)
-               $(cmake-utils_use_find_package svg RSVG)
-               $(cmake-utils_use_find_package tiff TIFF)
-               $(cmake-utils_use_find_package truetype Freetype)
-               $(cmake-utils_use_find_package vnc LibVNCServer)
+               $(cmake_use_find_package pdf Poppler-glib)
+               $(cmake_use_find_package png PNG)
+               $(cmake_use_find_package sdl SDL)
+               $(cmake_use_find_package sdl2 SDL2)
+               $(cmake_use_find_package svg RSVG)
+               $(cmake_use_find_package tiff TIFF)
+               $(cmake_use_find_package truetype Freetype)
+               $(cmake_use_find_package vnc LibVNCServer)
                -DOSGVIEWER_USE_XRANDR=$(usex xrandr)
-               $(cmake-utils_use_find_package zlib ZLIB)
+               $(cmake_use_find_package zlib ZLIB)
        )
        if use examples; then
                mycmakeargs+=(
-                       $(cmake-utils_use_find_package fltk FLTK)
-                       $(cmake-utils_use_find_package fox FOX)
-                       $(cmake-utils_use_find_package glut GLUT)
-                       $(cmake-utils_use_find_package wxwidgets wxWidgets)
+                       $(cmake_use_find_package fltk FLTK)
+                       $(cmake_use_find_package fox FOX)
+                       $(cmake_use_find_package glut GLUT)
+                       $(cmake_use_find_package wxwidgets wxWidgets)
                )
        fi
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_compile() {
-       cmake-utils_src_compile
-       use doc && cmake-utils_src_compile doc_openscenegraph doc_openthreads
+       cmake_src_compile
+       use doc && cmake_src_compile doc_openscenegraph doc_openthreads
 }
index 37c14d9804c59ba65b29c88529dbf2109e5a053b..774fa791efd566499b01b4fc672659b9141a69f4 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=7
 
+CMAKE_ECLASS=cmake
 inherit cmake-multilib
 
 DESCRIPTION="Abstraction layer for filesystem and archive access"
@@ -40,14 +41,14 @@ multilib_src_configure() {
                -DPHYSFS_ARCHIVE_QPAK="$(usex qpak)"
                -DPHYSFS_ARCHIVE_ZIP="$(usex zip)"
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 multilib_src_compile() {
-       cmake-utils_src_compile
+       cmake_src_compile
 
        if multilib_is_native_abi && use doc; then
-               cmake-utils_src_compile docs
+               cmake_src_compile docs
                HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
        fi
 }
index dbaa669aacc9091404e3fd33b014613502674362..9490039a10a7e261bd8c6207f4c1ef3952e220be 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=7
 
+CMAKE_ECLASS=cmake
 inherit cmake-multilib
 
 DESCRIPTION="Abstraction layer for filesystem and archive access"
@@ -40,14 +41,14 @@ multilib_src_configure() {
                -DPHYSFS_ARCHIVE_QPAK="$(usex qpak)"
                -DPHYSFS_ARCHIVE_ZIP="$(usex zip)"
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 multilib_src_compile() {
-       cmake-utils_src_compile
+       cmake_src_compile
 
        if multilib_is_native_abi && use doc; then
-               cmake-utils_src_compile docs
+               cmake_src_compile docs
                HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
        fi
 }
index 5117d81dff90ad5c0695bee3c7697c055438a87b..caf6ee16cf2e6a08c72b3c0f2f524c8ab2b6f5bf 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils desktop xdg-utils
+inherit cmake desktop xdg-utils
 
 COMMIT="42b6acd19af00689e8f34355e3b13323d8ea3f79"
 DATA_PV="0.8"
@@ -26,7 +26,7 @@ S="${WORKDIR}/${PN}-${COMMIT}"
 
 src_prepare() {
        ln -snf ../../${PN}-${DATA_PV}/data/{music,sfx} data/ || die
-       cmake-utils_src_prepare
+       cmake_src_prepare
 }
 
 src_configure() {
@@ -35,11 +35,11 @@ src_configure() {
                -DBUILD_SHARED_LIBS=OFF
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        doicon -s 32 doc/${PN}.png
        make_desktop_entry abuse Abuse
 }
index c2abf83066a13016a48a84df67ee1ed1da3c1e47..c6e92432e47d67d278da021429a08fecef078d95 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils desktop
+inherit cmake desktop
 
 DESCRIPTION="3D arcade with unique fighting system and anthropomorphic characters"
 HOMEPAGE="https://bitbucket.org/osslugaru/lugaru/wiki/Home"
@@ -32,7 +32,7 @@ PATCHES=(
 )
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        sed -i \
                -e "s:@GENTOO_DIR@:/usr/share/${PN}:" \
@@ -44,7 +44,7 @@ src_configure() {
                -DCMAKE_VERBOSE_MAKEFILE=TRUE
                -DLUGARU_FORCE_INTERNAL_OPENGL=False
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
index 96746c833f783a669e4c208ccdd0269457e91f27..1f2999ac01bbc6c57ce16f9991b5239c0d1edc6b 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils desktop xdg-utils
+inherit cmake desktop xdg-utils
 
 DESCRIPTION="A kart racing game starring Tux, the linux penguin (TuxKart fork)"
 HOMEPAGE="https://supertuxkart.net/"
@@ -56,7 +56,7 @@ PATCHES=(
 )
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        # remove bundled libraries, just to be sure
        rm -r lib/{angelscript,enet,glew,jpeglib,libpng,zlib} || die
@@ -78,11 +78,11 @@ src_configure() {
                -DSTK_INSTALL_DATA_DIR=share/${PN}
                -DBUILD_SHARED_LIBS=OFF # build bundled libsquish as static library
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        dodoc CHANGELOG.md
 
        doicon -s 64 "${DISTDIR}"/${PN}.png
index 7078f00ebd3fee51e411ab1b3fdce5f906e226bc..318f5c2470acc7cd672a14aa88099dbff5f90f68 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils desktop xdg-utils
+inherit cmake desktop xdg-utils
 
 DESCRIPTION="Help a girl named Violet in the struggle with hordes of monsters"
 HOMEPAGE="https://violetland.github.io/"
@@ -29,7 +29,7 @@ BDEPEND="
 "
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        # Bizarrely fcitx is only bundled for a CMake module to find libintl
        # but let's make sure the rest remains unused.
@@ -42,11 +42,11 @@ src_configure() {
                -DLOCALE_INSTALL_DIR=share/locale
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        dodoc CHANGELOG.md CONTRIBUTORS.md
 
        # Remove duplicate READMEs.
index e2625339eed678fc26264999181320282207b6e0..9aabfe025211c617992a8812ebf8607d1b99c607 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 PYTHON_COMPAT=( python3_{5,6,7} )
 
-inherit cmake-utils desktop python-single-r1 xdg-utils
+inherit cmake desktop python-single-r1 xdg-utils
 
 MY_PN="Commander-Genius"
 MY_P="${MY_PN}-v${PV}"
@@ -58,11 +58,11 @@ src_configure() {
                -DBUILD_SHARED_LIBS=OFF
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
 
        # The normal executable name is weird.
        dosym CGeniusExe /usr/bin/${PN}
index 8b9cc92724b5b71852fd3b1ba250ce919a9a9727..d855f92fd16f56c52fe777a1cf54a6c8b669c9b7 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils
+inherit cmake
 
 DESCRIPTION="A simple volleyball game"
 HOMEPAGE="http://slime.tuxfamily.org/index.php"
@@ -38,8 +38,7 @@ S="${WORKDIR}/${PN}"
 src_configure() {
        local mycmakeargs=(
                -DCMAKE_VERBOSE_MAKEFILE=TRUE
-               -DCMAKE_INSTALL_PREFIX=/usr
                -DDATA_DIR=/usr/share/slimevolley
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
index c12492e71e3cd89eb8cfee1fd008d0966495cdc9..4ce0d37323f41710352d41207534d54fe8c01100 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 : ${CMAKE_MAKEFILE_GENERATOR:=emake}
-inherit cmake-utils flag-o-matic
+inherit cmake flag-o-matic
 
 MY_P="SuperTux-v${PV}-Source"
 
@@ -37,7 +37,7 @@ PATCHES=(
 )
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        # This is not a developer release so switch the logo to the non-dev one.
        sed -e 's@logo_dev@logo@' \
@@ -56,5 +56,5 @@ src_configure() {
                -DENABLE_BOOST_STATIC_LIBS=OFF # bug! Please check if this is still required.
                -DUSE_SYSTEM_PHYSFS=ON
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
index dce1075f2829e418f6ca5b991cf458c80857514c..0964ce28665fd5dfeea65d9b77b4514b7aed7277 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 : ${CMAKE_MAKEFILE_GENERATOR:=emake}
-inherit cmake-utils flag-o-matic
+inherit cmake flag-o-matic
 
 MY_P="SuperTux-v${PV}-Source"
 
@@ -37,7 +37,7 @@ PATCHES=(
 )
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        # This is not a developer release so switch the logo to the non-dev one.
        sed -e 's@logo_dev@logo@' \
@@ -55,5 +55,5 @@ src_configure() {
                -DENABLE_SQDBG="$(usex debug)"
                -DUSE_SYSTEM_PHYSFS=ON
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
index b4a18e8d208672135742e55c3212c9a1753d7c4f..2c4ac0f47f1d62dad7faea2bec8ccf4aa18a2801 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils
+inherit cmake
 
 MY_PV="2019-03-04-Release-2.7.0"
 DESCRIPTION="An open-source multiplatform software for playing card games over a network"
@@ -67,5 +67,5 @@ src_configure() {
        sed -e 's/^set(PROJECT_VERSION_FRIENDLY.*/set(PROJECT_VERSION_FRIENDLY \"'${SHA1}'\")/' \
                -i cmake/getversion.cmake || die "sed failed!"
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
index a8f84107c83e3d5b048678d6cbc5bf4665931510..7c7a695b755a08db414feb9d65beb9a53ec2d42a 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 PYTHON_COMPAT=( python{2_7,3_{6,7}} )
-inherit cmake-utils python-single-r1 xdg
+inherit cmake python-single-r1 xdg
 
 DESCRIPTION="Atari ST emulator"
 HOMEPAGE="https://hatari.tuxfamily.org/"
@@ -48,7 +48,7 @@ DOCS=(
 
 src_prepare() {
        xdg_environment_reset
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        sed -i "s/\.1\.gz\b/.1/g;T;s/gzip[^\$]*/cat /g" {*/,}*/CMakeLists.txt || die
        sed -i "s:\"doc\" + sep + \"hatari\":\"doc/${PF}\":" python-ui/uihelpers.py || die
@@ -71,10 +71,10 @@ src_configure() {
                -DCMAKE_DISABLE_FIND_PACKAGE_Udev=$(usex !udev)
                -DCMAKE_DISABLE_FIND_PACKAGE_ZLIB=$(usex !zlib)
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        python_fix_shebang "${ED}"/usr/share/${PN}/
 }
index a8a2590c1f1ee67e9e46eb078ea9c4eb9c970871..b19935ad26861c3c90d580881850b7b5141a4a68 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 WX_GTK_VER="3.0-gtk3"
-inherit wxwidgets xdg cmake-utils
+inherit wxwidgets xdg cmake
 
 if [[ ${PV} == 9999 ]]; then
        EGIT_REPO_URI="https://github.com/visualboyadvance-m/visualboyadvance-m.git"
@@ -62,11 +62,11 @@ src_configure() {
                -DENABLE_ASM_SCALERS=$(usex x86)
                -DCMAKE_SKIP_RPATH=ON
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
 
        if use sdl ; then
                dodoc doc/ReadMe.SDL.txt
index f8607c8a0a0ecf94880766d03272c579b2e42663..29f851e02f7b28970d636cf7387f04e94f7ae86d 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 WX_GTK_VER="3.0-gtk3"
-inherit wxwidgets xdg cmake-utils
+inherit wxwidgets xdg cmake
 
 if [[ ${PV} == 9999 ]]; then
        EGIT_REPO_URI="https://github.com/visualboyadvance-m/visualboyadvance-m.git"
@@ -58,11 +58,11 @@ src_configure() {
                -DENABLE_ASM_SCALERS=$(usex x86)
                -DCMAKE_SKIP_RPATH=ON
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
 
        if use sdl ; then
                dodoc doc/ReadMe.SDL.txt
index 6a6f448a3fc25c957de6b5998dd66dde8b1f47fd..fe3b53da5e0de9483bccfe02666025d7ad90d1c8 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils xdg-utils readme.gentoo-r1
+inherit cmake xdg-utils readme.gentoo-r1
 
 DESCRIPTION="Open source reimplementation of TES III: Morrowind"
 HOMEPAGE="https://openmw.org/"
@@ -50,7 +50,7 @@ BDEPEND="
 S="${WORKDIR}/${PN}-${P}"
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        # We don't install license files
        sed -i '/LICDIR/d' CMakeLists.txt || die
@@ -79,14 +79,14 @@ src_configure() {
                -DDESIRED_QT_VERSION=5
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_compile() {
-       cmake-utils_src_compile
+       cmake_src_compile
 
        if use doc ; then
-               cmake-utils_src_compile doc
+               cmake_src_compile doc
                find "${CMAKE_BUILD_DIR}"/docs/Doxygen/html \
                        -name '*.md5' -type f -delete || die
                HTML_DOCS=( "${CMAKE_BUILD_DIR}"/docs/Doxygen/html/. )
@@ -94,7 +94,7 @@ src_compile() {
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
 
        local DOC_CONTENTS="
        You need the original Morrowind data files. If you haven't
index 757a7f8c47295525162e6c38fa9d37ece4c7558c..8eb5fd81fbeaa1249b714d9f61e634718a611075 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 PYTHON_COMPAT=( python2_7 python3_{6,7} )
 
-inherit cmake-utils python-any-r1 readme.gentoo-r1
+inherit cmake python-any-r1 readme.gentoo-r1
 
 DESCRIPTION="A modern gaming engine for Doom, Heretic, and Hexen"
 HOMEPAGE="https://www.dengine.net"
@@ -45,7 +45,7 @@ S="${WORKDIR}/${P}/${PN}"
 DOC_CONTENTS="You need to copy Doom, Doom 2, Chex Quest, Heretic, Hexen, HexenDD, or Doom64 wads to a folder of your choice and then tell the game engine where that folder is. This is different to older versions, which had separate launchers for each game and required the files to be in a specific place."
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        # Fix QA warning for "installing to one or more unexpected paths"
        sed -e "10s:/texc:/${PF}:" -i tools/texc/CMakeLists.txt || die
@@ -58,11 +58,11 @@ src_configure() {
                -DDENG_ENABLE_TOOLS="$(usex tools)"
                -DPYTHON_EXECUTABLE="${PYTHON}"
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
 
        if use tools; then
                mv -v "${ED}"/usr/bin/md2tool{,.${PN}} || die
index 54588481980490239edc5b1062a4f754888a1222..ad3f83ccf4faa36b7c44bc4cee3f289ed59d090f 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-inherit cmake-utils toolchain-funcs flag-o-matic xdg-utils
+inherit cmake toolchain-funcs flag-o-matic xdg-utils
 
 DESCRIPTION="free Lemmings clone"
 HOMEPAGE="http://pingus.gitlab.io/"
@@ -37,7 +37,7 @@ PATCHES=(
 
 src_prepare() {
        sed '/find_package(Boost/s@ signals@@' -i CMakeLists.txt || die
-       cmake-utils_src_prepare
+       cmake_src_prepare
        strip-flags
 }
 
index 5261c3d90c41d1e7e34cf1d05b67c98ef3994af3..9ce25df816030b9eef77d05739ae373a1f85e748 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 CMAKE_IN_SOURCE_BUILD="yes"
-inherit cmake-utils prefix
+inherit cmake prefix
 
 DESCRIPTION="The Dungeons of Moria, a single player roguelike game, also known as Umoria"
 HOMEPAGE="https://umoria.org/"
@@ -28,7 +28,7 @@ PATCHES=(
 )
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
        sed -i "s/@PF@/${PF}/" src/config.cpp || die
        hprefixify src/config.cpp
 }
index 9e8d0f6b128927a62f641322af74cd720f4f04e3..a30e287caed402083d07e8836bf9c650a57d1e4a 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 CMAKE_MAKEFILE_GENERATOR=emake
-inherit cmake-utils xdg-utils
+inherit cmake xdg-utils
 
 MY_P=${PN}-src-${PV}
 
@@ -88,11 +88,11 @@ src_configure() {
                # https://bugzilla.redhat.com/show_bug.cgi?id=1200193
                -DCMAKE_SKIP_RPATH=ON
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        doman man/${PN}.6
 }
 
index 510a59e68be9651c10010dea9ef60d2d5f5066b8..06ff63ec4324915462d6f2fa0266f2c9daefacd8 100644 (file)
@@ -2,7 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-inherit cmake-utils user
+
+inherit cmake user
 
 DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
 HOMEPAGE="http://www.wesnoth.org
@@ -55,7 +56,7 @@ pkg_setup() {
 }
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        if ! use doc ; then
                sed -i \
@@ -106,14 +107,13 @@ src_configure() {
                -DENABLE_FRIBIDI="$(usex fribidi)"
                -DENABLE_OMP="$(usex openmp)"
                -DENABLE_STRICT_COMPILATION="OFF"
-               -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
                )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
        local DOCS=( README.md changelog.md )
-       cmake-utils_src_install
+       cmake_src_install
        if use dedicated || use server; then
                rmdir "${ED}/run/wesnothd" || die
                newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd
index 807170165f0b3256dbda7c817a1d670237e85498..0451aedf6acf5360cd6778e433293df459d9dfed 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils user xdg
+inherit cmake user xdg
 
 DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
 HOMEPAGE="http://www.wesnoth.org
@@ -50,7 +50,7 @@ pkg_setup() {
 }
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        if ! use doc ; then
                sed -i \
@@ -100,14 +100,13 @@ src_configure() {
                -DENABLE_NOTIFICATIONS="$(usex dbus)"
                -DENABLE_FRIBIDI="$(usex fribidi)"
                -DENABLE_STRICT_COMPILATION="OFF"
-               -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
                )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
        local DOCS=( README.md changelog.md )
-       cmake-utils_src_install
+       cmake_src_install
        if use dedicated || use server; then
                rmdir "${ED}/run/wesnothd" || die
                newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd
index 807170165f0b3256dbda7c817a1d670237e85498..0451aedf6acf5360cd6778e433293df459d9dfed 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils user xdg
+inherit cmake user xdg
 
 DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
 HOMEPAGE="http://www.wesnoth.org
@@ -50,7 +50,7 @@ pkg_setup() {
 }
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        if ! use doc ; then
                sed -i \
@@ -100,14 +100,13 @@ src_configure() {
                -DENABLE_NOTIFICATIONS="$(usex dbus)"
                -DENABLE_FRIBIDI="$(usex fribidi)"
                -DENABLE_STRICT_COMPILATION="OFF"
-               -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
                )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
        local DOCS=( README.md changelog.md )
-       cmake-utils_src_install
+       cmake_src_install
        if use dedicated || use server; then
                rmdir "${ED}/run/wesnothd" || die
                newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd
index b1bdd26773386b3681a49a5020dc0e8392aab962..2ccf31fe16ebd9d4a9ef1b5f825012f3bc47f32c 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit desktop cmake-utils
+inherit desktop cmake
 
 MY_PV="build$(ver_cut 2-)"
 MY_P="${PN}-${MY_PV/_/-}"
@@ -43,7 +43,7 @@ PATCHES=(
 )
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        sed -i -e 's:__ppc__:__PPC__:' src/map_io/s2map.cc || die
 }
@@ -57,11 +57,11 @@ src_configure() {
                # Game is NOT happy being moved from /usr/share/games
                -DWL_INSTALL_DATADIR="${EPREFIX}"/usr/share/games/${PN}
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
 
        # move game binary to correct location
        dodir /usr/bin
index 9cfddcf425f92d63b06e52fab51d35e234e94eb4..aaff95f0bbf1f34cc5f23f95a0394a75e91a5774 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit desktop cmake-utils
+inherit desktop cmake
 
 MY_PV="build$(ver_cut 2-)"
 MY_P="${PN}-${MY_PV/_/-}"
@@ -43,7 +43,7 @@ PATCHES=(
 )
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        sed -i -e 's:__ppc__:__PPC__:' src/map_io/s2map.cc || die
 }
@@ -57,11 +57,11 @@ src_configure() {
                # Game is NOT happy being moved from /usr/share/games
                -DWL_INSTALL_DATADIR="${EPREFIX}"/usr/share/games/${PN}
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
 
        # move game binary to correct location
        dodir /usr/bin
index 9a73f51a45c842f4504b879bb11e5888f69d101b..bd02b105269bd3c1f480646fbea3f54c69baaf7e 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils
+inherit cmake
 
 DESCRIPTION="Unofficial GOG.com downloader for Linux"
 HOMEPAGE="https://sites.google.com/site/gogdownloader/"
@@ -35,10 +35,10 @@ src_configure() {
        local mycmakeargs=(
                -DUSE_QT_GUI=$(usex gui)
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        gunzip "${ED}"/usr/share/man/man1/${PN}.1.gz || die
 }
index d0d1304d0133cde62e3bb306677437466078de60..37dfd7c2f858aeb967c164a68f96eb5c35ce4d71 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils git-r3
+inherit cmake git-r3
 
 DESCRIPTION="Unofficial GOG.com downloader for Linux"
 HOMEPAGE="https://sites.google.com/site/gogdownloader/"
@@ -30,10 +30,10 @@ src_configure() {
        local mycmakeargs=(
                -DUSE_QT_GUI=$(usex gui)
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        gunzip "${ED}"/usr/share/man/man1/${PN}.1.gz || die
 }
index bbe3cb1a257690b5f6fdd28d3195b2f2d65c1497..ba8e0cec815fd84f52767c514e042fe7417af3a2 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils desktop
+inherit cmake desktop
 
 DESCRIPTION="Translate gamepad/joystick input into key strokes/mouse actions in X"
 HOMEPAGE="https://github.com/panzi/qjoypad"
@@ -33,7 +33,7 @@ DEPEND="${RDEPEND}
 PATCHES=( "${FILESDIR}/${PN}-4.3.0-cmake.patch" )
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
 
        local i
        cd icons || die
index f948ce3df0ba21f7d9b61f39f6334f1c717b3cfc..a519c81c044458a4460c4c0f55aafaea02ce2b0f 100644 (file)
@@ -38,5 +38,5 @@ multilib_src_configure() {
                -DBUILD_RECORDER_WITH_SOUND=$(usex sound)
                -DBUILD_WITH_VPX=$(usex vpx)
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }