*/*: Switch games proj to cmake.eclass
[gentoo.git] / games-util / lgogdownloader / lgogdownloader-3.5.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake
7
8 DESCRIPTION="Unofficial GOG.com downloader for Linux"
9 HOMEPAGE="https://sites.google.com/site/gogdownloader/"
10 SRC_URI="https://sites.google.com/site/gogdownloader/${P}.tar.gz"
11 LICENSE="WTFPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="gui"
15
16 RDEPEND=">=app-crypt/rhash-1.3.3-r2:0=
17         dev-cpp/htmlcxx:0=
18         dev-libs/boost:0=
19         >=dev-libs/jsoncpp-1.7:0=
20         dev-libs/tinyxml2:0=
21         net-libs/liboauth:0=
22         >=net-misc/curl-7.32:0=[ssl]
23         gui? ( dev-qt/qtwebengine:5=[widgets] )"
24
25 DEPEND="${RDEPEND}"
26
27 BDEPEND="sys-apps/help2man
28         virtual/pkgconfig"
29
30 PATCHES=(
31         "${FILESDIR}"/jsoncpp.patch
32 )
33
34 src_configure() {
35         local mycmakeargs=(
36                 -DUSE_QT_GUI=$(usex gui)
37         )
38         cmake_src_configure
39 }
40
41 src_install() {
42         cmake_src_install
43         gunzip "${ED}"/usr/share/man/man1/${PN}.1.gz || die
44 }