webtest-*.ebuild: Install lint3 for Python 3
[wtk-overlay.git] / webtest-1.4.3.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header$
4
5 EAPI="3"
6 PYTHON_DEPEND="2:2.6 3:3.2"
7 SUPPORT_PYTHON_ABIS="1"
8 RESTRICT_PYTHON_ABIS="2.5 3.1"
9 PYTHON_TESTS_RESTRICTED_ABIS="*-pypy-*"
10 DISTUTILS_SRC_TEST="nosetests"
11
12 inherit distutils
13
14 MY_PN="WebTest"
15 MY_P="${MY_PN}-${PV}"
16
17 DESCRIPTION="Helper to test WSGI applications"
18 HOMEPAGE="http://pythonpaste.org/webtest/ http://pypi.python.org/pypi/WebTest"
19 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
20
21 LICENSE="MIT"
22 SLOT="0"
23 KEYWORDS="~alpha amd64 arm ~hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
24 IUSE="doc"
25
26 RDEPEND=">=dev-python/webob-0.9.2"
27 DEPEND="${RDEPEND}
28         app-arch/unzip
29         dev-python/setuptools
30         doc? ( dev-python/sphinx )
31         test? ( dev-python/pyquery )"
32
33 S="${WORKDIR}/${MY_P}"
34
35 src_compile() {
36         distutils_src_compile
37
38         if use doc; then
39                 einfo "Generation of documentation"
40                 sphinx-build docs html || die "Building of documentation failed"
41         fi
42 }
43
44 src_install() {
45         distutils_src_install
46
47         if use doc; then
48                 dohtml -r html/*
49         fi
50 }