thumbor-pexif-0.14.1.ebuild: Dead ebuild for thumbor (which wants <1.0)
[wtk-overlay.git] / thumbor-pexif-9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit distutils-r1
9
10 if [[ "${PV}" == "9999" ]]; then
11         inherit git-2
12         EGIT_REPO_URI="git://github.com/thumbor/pexif.git"
13         SRC_URI=""
14 else
15         SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
16 fi
17
18 DESCRIPTION="Edit JPEG EXIF data"
19 HOMEPAGE="https://github.com/thumbor/pexif https://pypi.python.org/pypi/thumbor-pexif"
20
21 LICENSE="MIT"
22 SLOT="0"
23 KEYWORDS="~amd64 ~x86"
24 IUSE="test"
25
26 RDEPEND=""
27 DEPEND=""
28
29 python_test() {
30         PYTHONPATH=. "${EPYTHON}" ./test/test.py
31 }