Merge remote-tracking branch 'origin/dev-python/raven'
[wtk-overlay.git] / sci-libs / pycomedi / pycomedi-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="4"
6 PYTHON_DEPEND="2:2.6 3:3.2"
7 SUPPORT_PYTHON_ABIS="1"
8 RESTRICT_PYTHON_ABIS="3.[01]"
9
10 inherit eutils distutils
11
12 if [[ ${PV} == "9999" ]] ; then
13         inherit git-2
14         EGIT_REPO_URI="git://tremily.us/${PN}.git"
15         SRC_URI=""
16 else
17         SRC_URI="http://git.tremily.us/?p=${PN}.git;a=snapshot;h=v${PV};sf=tgz"
18 fi
19
20 DESCRIPTION="Pythonic wrappers around the Comedilib device drivers."
21 HOMEPAGE="http://blog.tremily.us/posts/${PN}/"
22
23 LICENSE="GPL-3"
24 SLOT="0"
25 KEYWORDS="~x86 ~amd64"
26 IUSE="doc +kmod test"
27
28 RDEPEND="sci-libs/comedilib[python]
29         dev-python/numpy
30         sci-libs/scipy
31         kmod? ( dev-python/python-kmod )"
32 DEPEND="$RDEPEND
33         >=dev-python/cython-0.14
34         test? ( dev-python/nose )"
35
36 src_install() {
37         distutils_src_install
38         dodoc README
39         if use doc; then
40                 dodoc -r doc/
41         fi
42 }