205b5deb7b9cfbc7a5915acc5bf17e1f0706a424
[wtk-overlay.git] / sci-libs / pyafm / pyafm-9999.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6 PYTHON_DEPEND="2:2.6"
7 SUPPORT_PYTHON_ABIS="1"
8 RESTRICT_PYTHON_ABIS="3.*"
9
10 inherit eutils distutils
11
12 if [[ ${PV} == "9999" ]] ; then
13         inherit git
14         EGIT_REPO_URI="http://www.physics.drexel.edu/~wking/code/git/${PN}.git"
15         SRC_URI=""
16 else
17         SRC_URI="http://www.physics.drexel.edu/~wking/code/got/gitweb.cgi?p=${PN}.git;a=snapshot;h=v${PV};sf=tgz"
18 fi
19
20 DESCRIPTION="Tools for controlling atomic force microscopes."
21 HOMEPAGE="http://http://www.physics.drexel.edu/~wking/unfolding-disasters/posts/${PN}/"
22
23 LICENSE="GPL-3"
24 SLOT="0"
25 KEYWORDS="~x86"
26 IUSE="test"
27
28 RDEPEND="sci-libs/pypiezo"
29 DEPEND="$RDEPEND
30         test? ( dev-python/nose )"
31
32 src_unpack() {
33         if [[ ${PV} == "9999" ]] ; then
34                 git_src_unpack
35         else
36                 unpack ${A}
37         fi
38         cd "${S}"
39 }
40
41 src_install() {
42         distutils_src_install
43         dodoc README
44 }