raven-9999: Convert the old 2.0.10 ebuild into a live ebuild
[wtk-overlay.git] / raven-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="5"
6 PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
7
8 inherit distutils-r1
9
10 if [[ "${PV}" == "9999" ]]; then
11         inherit git-2
12         EGIT_REPO_URI="git://github.com/getsentry/${PN}-python.git"
13         SRC_URI=""
14 else
15         SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
16 fi
17
18 DESCRIPTION="Raven is a client for Sentry"
19 HOMEPAGE="http://github.com/getsentry/raven-python"
20
21 LICENSE="BSD"
22 SLOT="0"
23 KEYWORDS="~amd64 ~x86"
24 IUSE="test"
25
26 RDEPEND=""
27 DEPEND="${RDEPEND}
28         test? (
29                 dev-python/anyjson[${PYTHON_USEDEP}]
30                 >=dev-python/blinker-1.1[${PYTHON_USEDEP}]
31                 dev-python/bottle[${PYTHON_USEDEP}]
32                 >=dev-python/celery-2.5[${PYTHON_USEDEP}]
33                 >=dev-python/django-1.4[${PYTHON_USEDEP}]
34                 >=dev-python/django-celery-2.5[${PYTHON_USEDEP}]
35                 >=dev-python/exam-0.5.2[${PYTHON_USEDEP}]
36                 >=dev-python/flask-0.8[${PYTHON_USEDEP}]
37                 >=dev-python/flask-login-0.2.0[${PYTHON_USEDEP}]
38                 dev-python/logbook[${PYTHON_USEDEP}]
39                 dev-python/mock[${PYTHON_USEDEP}]
40                 dev-python/nose[${PYTHON_USEDEP}]
41                 dev-python/pep8[${PYTHON_USEDEP}]
42                 dev-python/pytest[${PYTHON_USEDEP}]
43                 >=dev-python/pytest-cov-1.4[${PYTHON_USEDEP}]
44                 dev-python/pytest-django[${PYTHON_USEDEP}]
45                 dev-python/pytz[${PYTHON_USEDEP}]
46                 dev-python/webob[${PYTHON_USEDEP}]
47                 dev-python/webtest[${PYTHON_USEDEP}]
48                 www-servers/tornado[${PYTHON_USEDEP}]
49                 python_targets_python3_3? (
50                         dev-python/aiohttp[python_targets_python3_3]
51                 )
52                 python_targets_python3_4? (
53                         dev-python/aiohttp[python_targets_python3_4]
54                 )
55                 python_targets_python2_7? (
56                         dev-python/paste[python_targets_python2_7]
57                         dev-python/unittest2[python_targets_python2_7]
58                         dev-python/webpy[python_targets_python2_7]
59                 )
60         )"
61
62 python_test() {
63         py.test || die "Testsuite failed under ${EPYTHON}"
64 }