Merge remote-tracking branch 'laurentb/dev-python/pytest-xdist'
[wtk-overlay.git] / pytest-xdist-9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6 PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
7
8 inherit distutils-r1
9
10 if [[ "${PV}" == "9999" ]]; then
11         inherit mercurial
12         EHG_REPO_URI="https://bitbucket.org/hpk42/pytest-xdist"
13         SRC_URI=""
14 else
15         SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
16 fi
17
18 DESCRIPTION="A distributed testing plugin for py.test"
19 HOMEPAGE="https://bitbucket.org/hpk42/pytest-xdist https://pypi.python.org/pypi/pytest-xdist"
20
21 LICENSE="MIT"
22 SLOT="0"
23 KEYWORDS="~amd64 ~x86"
24 IUSE="test"
25
26 RDEPEND="
27         >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}]
28         >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
29         >=dev-python/execnet-1.1[${PYTHON_USEDEP}]
30         "
31 DEPEND="
32         dev-python/setuptools[${PYTHON_USEDEP}]
33         test? (
34                 ${RDEPEND}
35         )"
36
37 DOCS=( CHANGELOG README.txt )
38
39 python_test() {
40         distutils_install_for_testing
41         py.test || die "Testsuite failed under ${EPYTHON}"
42 }