a25276bdee22180178bac7063d6b8aca21fb4661
[wtk-overlay.git] / pytest-xdist-1.10.ebuild
1 # Copyright 2012-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="py.test xdist plugin for distributed testing and loop-on-failing"
11 HOMEPAGE="https://pypi.python.org/pypi/pytest-xdist
12 https://bitbucket.org/hpk42/pytest-xdist"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x64"
18 IUSE=""
19
20 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
21 RDEPEND=">=dev-python/pytest-2.3.5[${PYTHON_USEDEP}]
22         >=dev-python/execnet-1.1[${PYTHON_USEDEP}]"
23
24 DOCS=( CHANGELOG LICENSE README.txt )