pyssim-9999.ebuild: Add ebuild
[wtk-overlay.git] / pyssim-9999.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=6
6 PYTHON_COMPAT=( python{2_7,3_4} )
7
8 inherit distutils-r1
9
10 if [[ "${PV}" == "9999" ]]; then
11         inherit git-r3
12         EGIT_REPO_URI="git://github.com/jterrace/${PN}.git"
13         SRC_URI=""
14 else
15         SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
16 fi
17
18 DESCRIPTION="Implements the Structural Similarity Image Metric (SSIM)"
19 HOMEPAGE="https://github.com/jterrace/pyssim https://pypi.python.org/pypi/pyssim"
20
21 LICENSE="MIT"
22 SLOT="0"
23 KEYWORDS="~amd64 ~x86"
24
25 RDEPEND="
26         dev-python/numpy[${PYTHON_USEDEP}]
27         dev-python/pillow[${PYTHON_USEDEP}]
28         sci-libs/scipy[${PYTHON_USEDEP}]
29         "
30
31 DEPEND="${RDEPEND}"