ChangeLog: Drop this optional file
[wtk-overlay.git] / pyassuan-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="4"
6 PYTHON_DEPEND="3:3.3"
7 SUPPORT_PYTHON_ABIS="1"
8 RESTRICT_PYTHON_ABIS="2.* 3.[012]"
9
10 inherit eutils distutils
11
12 if [[ ${PV} == "9999" ]] ; then
13         inherit git-2
14         EGIT_BRANCH="master"
15         EGIT_REPO_URI="git://tremily.us/${PN}.git"
16         SRC_URI=""
17 else
18         SRC_URI="http://git.tremily.us/?p=${PN}.git;a=snapshot;h=v${PV};sf=tgz"
19 fi
20
21 DESCRIPTION="Python module and tools for communicating in the Assuan protocol."
22 HOMEPAGE="http://blog.tremily.us/posts/${PN}"
23
24 LICENSE="GPL-3"
25 SLOT="0"
26 KEYWORDS="~amd64 ~x86"
27 IUSE="doc test"
28
29 RDEPEND=""
30 DEPEND="${RDEPEND}
31         test? ( dev-python/nose )"
32
33 src_unpack() {
34         if [[ ${PV} == "9999" ]] ; then
35                 git-2_src_unpack
36         else
37                 unpack ${A}
38         fi
39         cd "${S}"
40 }
41
42 src_install() {
43         distutils_src_install
44         dodoc README
45 }