dev-python/preggy: Add this (indirect) thumbor test dependency
[wtk-overlay.git] / preggy-9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6 PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
7
8 inherit distutils-r1
9
10 if [[ "${PV}" == "9999" ]]; then
11         inherit git-2
12         EGIT_REPO_URI="git://github.com/heynemann/${PN}.git"
13         SRC_URI=""
14 else
15         SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
16 fi
17
18 DESCRIPTION="An assertion library for Python"
19 HOMEPAGE="http://heynemann.github.io/preggy https://pypi.python.org/pypi/preggy"
20
21 LICENSE="MIT"
22 SLOT="0"
23 KEYWORDS="~amd64 ~x86"
24 IUSE="test"
25
26 RDEPEND="
27         dev-python/six[${PYTHON_USEDEP}]
28         dev-python/unidecode[${PYTHON_USEDEP}]
29         "
30 DEPEND="
31         test? (
32                 ${RDEPEND}
33                 dev-python/nose[${PYTHON_USEDEP}]
34                 dev-python/coverage[${PYTHON_USEDEP}]
35         )"
36
37 python_prepare_all() {
38         sed -i "s/packages=find_packages()/packages=find_packages(exclude=['tests', 'tests.*'])/" setup.py || die
39         distutils-r1_python_prepare_all
40 }
41
42 python_test() {
43         "${EPYTHON}" -c 'import nose; nose.run_exit()' -vv --detailed-errors --with-coverage --cover-package=preggy --cover-package=preggy.assertions --cover-package=preggy.assertions.types tests/ ||
44         die "tests failed with ${EPYTHON}"
45 }