3da272ce5b017779f72feaa5afc7c705dcf9b81d
[wtk-overlay.git] / execnet-1.2.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python{2_6,2_7,3_2} pypy pypy2_0 )
8
9 inherit distutils-r1
10
11 DESCRIPTION="Rapid multi-Python deployment"
12 HOMEPAGE="http://codespeak.net/execnet/ http://pypi.python.org/pypi/execnet/"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="doc"
19
20 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
21         doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
22 RDEPEND=""
23
24 python_compile_all() {
25         use doc && emake -C doc html
26 }
27
28 src_test() {
29         # Tests are a bit fragile to failures in parallel.
30         # XXX: take a closer look, it may be easy to fix.
31         local DISTUTILS_NO_PARALLEL_BUILD=1
32
33         distutils-r1_src_test
34 }
35
36 python_test() {
37         # Re-enable in order to properly test disabling it ;).
38         # https://bitbucket.org/hpk42/execnet/issue/10
39         unset PYTHONDONTWRITEBYTECODE
40
41         py.test || die "Tests fail with ${EPYTHON}"
42 }
43
44 python_install_all() {
45         use doc && local HTML_DOCS=( doc/_build/html/. )
46
47         distutils-r1_python_install_all
48 }