c4c2cb7b0917210ba177010f31cb22fdf3741b4c
[wtk-overlay.git] / execnet-1.0.9.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header$
4
5 EAPI="3"
6 SUPPORT_PYTHON_ABIS="1"
7 DISTUTILS_SRC_TEST="py.test"
8
9 inherit distutils
10
11 DESCRIPTION="Rapid multi-Python deployment"
12 HOMEPAGE="http://codespeak.net/execnet/ http://pypi.python.org/pypi/execnet/"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="doc"
19
20 DEPEND="app-arch/unzip
21         dev-python/setuptools
22         doc? ( dev-python/sphinx )"
23 RDEPEND=""
24
25 src_compile() {
26         distutils_src_compile
27
28         if use doc; then
29                 einfo "Generation of documentation"
30                 cd doc
31                 emake html || die "Generation of documentation failed"
32         fi
33 }
34
35 src_test() {
36         distutils_src_test testing
37 }
38
39 src_install() {
40         distutils_src_install
41
42         if use doc; then
43                 dohtml -r doc/_build/html/* || die "Installation of documentation failed"
44         fi
45 }