dev-python/django-configurations: Add this Raven test dependency
[wtk-overlay.git] / django-configurations-9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6 PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
7
8 inherit distutils-r1
9
10 if [[ "${PV}" == "9999" ]]; then
11         inherit git-2
12         EGIT_REPO_URI="git://github.com/jezdez/${PN}.git"
13         SRC_URI=""
14 else
15         SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
16 fi
17
18 DESCRIPTION="A helper for organizing Django project settings"
19 HOMEPAGE="http://django-configurations.readthedocs.org/ https://pypi.python.org/pypi/django-configurations"
20
21 LICENSE="BSD"
22 SLOT="0"
23 KEYWORDS="~amd64 ~x86"
24 IUSE="test"
25
26 RDEPEND="
27         dev-python/dj-database-url[${PYTHON_USEDEP}]
28         dev-python/dj-email-url[${PYTHON_USEDEP}]
29         dev-python/django[${PYTHON_USEDEP}]
30         dev-python/django-cache-url[${PYTHON_USEDEP}]
31         "
32 DEPEND="
33         dev-python/setuptools[${PYTHON_USEDEP}]
34         test? (
35                 ${RDEPEND}
36         )"
37
38 python_test() {
39         "${EPYTHON}" manage.py test -v2 --failfast
40 }