25741c16779228343dd8843196936c1dce4679fc
[wtk-overlay.git] / dev-util / update-copyright / update-copyright-9999.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="6"
6 PYTHON_COMPAT=( python{3_2,3_3,3_4,3_5,3_6} )
7
8 inherit eutils distutils-r1
9
10 if [[ "${PV}" == "9999" ]] ; then
11         inherit git-r3
12         EGIT_REPO_URI="git://tremily.us/${PN}.git"
13         SRC_URI=""
14 else
15         SRC_URI="http://git.tremily.us/?p=${PN}.git;a=snapshot;h=v${PV};sf=tgz -> ${P}.tar.gz"
16 fi
17
18 DESCRIPTION="Automatically update copyright blurbs in versioned source."
19 HOMEPAGE="http://blog.tremily.us/posts/update-copyright/"
20
21 LICENSE="GPL-3"
22 SLOT="0"
23 KEYWORDS="~amd64 ~x86"