Merge remote-tracking branch 'origin/dev-python/exam'
[wtk-overlay.git] / dev-python / wheel / wheel-9999.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="5"
6 PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A built-package format for Python"
11 HOMEPAGE="https://bitbucket.org/dholth/wheel/ http://pypi.python.org/pypi/wheel"
12 if [[ "${PV}" == "9999" ]]; then
13         inherit mercurial
14         EHG_REPO_URI="https://bitbucket.org/dholth/wheel"
15         SRC_URI=""
16 else
17         SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
18 fi
19
20 LICENSE="MIT"
21 SLOT="0"
22 KEYWORDS="~amd64 ~x86"
23 IUSE="doc"
24
25 RDEPEND="${PYTHON_DEPS}"
26 DEPEND="${RDEPEND}"
27
28 src_install() {
29         distutils-r1_src_install
30         dodoc README.txt
31         if use doc; then
32                 dodoc -r docs
33         fi
34 }