Merge branch 'dev-python/pyvows'
[wtk-overlay.git] / dev-python / pytest-django / pytest-django-9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6 PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
7
8 inherit distutils-r1
9
10 if [[ "${PV}" == "9999" ]]; then
11         inherit git-2
12         EGIT_REPO_URI="git://github.com/pytest-dev/${PN}.git"
13         SRC_URI=""
14 else
15         SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
16 fi
17
18 DESCRIPTION="A Django plugin for py.test"
19 HOMEPAGE="http://pytest-django.readthedocs.org/ https://pypi.python.org/pypi/pytest-django"
20
21 LICENSE="BSD"
22 SLOT="0"
23 KEYWORDS="~amd64 ~x86"
24 IUSE="test"
25
26 RDEPEND=">=dev-python/pytest-2.5[${PYTHON_USEDEP}]"
27 DEPEND="
28         dev-python/setuptools[${PYTHON_USEDEP}]
29         "