Merge remote-tracking branch 'origin/dev-python/raven'
[wtk-overlay.git] / dev-python / pypid / pypid-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="4"
6
7 PYTHON_DEPEND="2:2.7"
8 SUPPORT_PYTHON_ABIS="1"
9 RESTRICT_PYTHON_ABIS="3.*"
10
11 inherit eutils distutils
12
13 if [[ ${PV} == "9999" ]] ; then
14         inherit git-2
15         EGIT_REPO_URI="git://tremily.us/${PN}.git"
16         SRC_URI=""
17 else
18         SRC_URI="http://git.tremily.us/?p=${PN}.git;a=snapshot;h=v${PV};sf=tgz"
19 fi
20
21 DESCRIPTION="Modular PID control library."
22 HOMEPAGE="http://blog.tremily.us/posts/${PN}/"
23
24 LICENSE="GPL-3"
25 SLOT="0"
26 KEYWORDS="~x86 ~amd64"
27 IUSE="modbus serial"
28
29 RDEPEND="dev-python/numpy
30         >=media-libs/aubio-0.3.2-r3
31         sci-libs/scipy
32         modbus? (
33                 dev-python/pymodbus[serial?]
34         )"
35 DEPEND="${RDEPEND}"
36
37 src_unpack() {
38         if [[ ${PV} == "9999" ]] ; then
39                 git-2_src_unpack
40         else
41                 unpack ${A}
42         fi
43         cd "${S}"
44 }
45
46 src_install() {
47         distutils_src_install
48         dodoc README
49         dodoc -r examples
50 }