Merge remote-tracking branch 'origin/dev-python/execnet'
[wtk-overlay.git] / dev-python / pygrader / pygrader-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="4"
6 PYTHON_DEPEND="3:3.2"
7 SUPPORT_PYTHON_ABIS="1"
8 RESTRICT_PYTHON_ABIS="2.* 3.[01]"
9
10 inherit eutils distutils
11
12 if [[ ${PV} == "9999" ]] ; then
13         inherit git-2
14         EGIT_BRANCH="master"
15         EGIT_REPO_URI="git://tremily.us/${PN}.git"
16         SRC_URI=""
17 else
18         SRC_URI="http://git.tremily.us/?p=${PN}.git;a=snapshot;h=v${PV};sf=tgz"
19 fi
20
21 DESCRIPTION="Python tools for dealing with Pretty Good Privacy (PGP) and email."
22 HOMEPAGE="http://blog.tremily.us/posts/${PN}"
23
24 LICENSE="GPL-3"
25 SLOT="0"
26 KEYWORDS="~amd64 ~x86"
27 IUSE="doc test"
28
29 RDEPEND="dev-python/jinja
30         dev-python/numpy
31         dev-python/pgp-mime"
32 DEPEND="${RDEPEND}
33         test? ( dev-python/nose )"
34
35 src_unpack() {
36         if [[ ${PV} == "9999" ]] ; then
37                 git-2_src_unpack
38         else
39                 unpack ${A}
40         fi
41         cd "${S}"
42 }
43
44 src_install() {
45         distutils_src_install
46         dodoc README
47         if use doc; then
48                 dodoc -r test
49         fi
50 }