2742968d2c7f4dd808097cda574ddb0bde1bc5fd
[wtk-overlay.git] / dev-python / pyassuan / pyassuan-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="6"
6 PYTHON_COMPAT=( python{3_3,3_4,3_5,3_6} )
7
8 inherit eutils distutils-r1
9
10 if [[ ${PV} == "9999" ]] ; then
11         inherit git-r3
12         EGIT_REPO_URI="git://tremily.us/${PN}.git"
13         SRC_URI=""
14 else
15         SRC_URI="http://git.tremily.us/?p=${PN}.git;a=snapshot;h=v${PV};sf=tgz"
16 fi
17
18 DESCRIPTION="Python module and tools for communicating in the Assuan protocol."
19 HOMEPAGE="http://blog.tremily.us/posts/${PN}"
20
21 LICENSE="GPL-3"
22 SLOT="0"
23 KEYWORDS="~amd64 ~x86"
24 IUSE="doc test"
25
26 RDEPEND=""
27 DEPEND="${RDEPEND}"
28
29 src_unpack() {
30         if [[ ${PV} == "9999" ]] ; then
31                 git-r3_src_unpack
32         else
33                 unpack ${A}
34         fi
35         cd "${S}"
36 }
37
38 src_install() {
39         distutils-r1_src_install
40         dodoc README
41 }