dev-python/parse: Add this Fig dependency (via dockerpty and behave)
[wtk-overlay.git] / dev-python / parse / parse-9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="5"
6 PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Parse strings using a specification based on the Python format() syntax."
11 HOMEPAGE="https://github.com/r1chardj0n3s/parse http://pypi.python.org/pypi/parse"
12 if [[ "${PV}" == "9999" ]]; then
13         inherit git-2
14         EGIT_REPO_URI="git://github.com/r1chardj0n3s/parse.git"
15         SRC_URI=""
16 else
17         SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
18 fi
19
20 LICENSE="BSD-2"
21 SLOT="0"
22 KEYWORDS="~amd64 ~x86"
23 IUSE="test"
24 DOCS="README.rst"
25
26 RDEPEND="${PYTHON_DEPS}"
27 DEPEND="${RDEPEND}"
28
29 python_test() {
30         "${PYTHON}" test_parse.py || die "Tests failed with ${EPYTHON}"
31 }