b220b43e7d8962918bb0ecccb09f11ef1dfc3ffd
[wtk-overlay.git] / dev-python / libthumbor / libthumbor-9999.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=6
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit distutils-r1
9
10 if [[ "${PV}" == "9999" ]]; then
11         inherit git-r3
12         EGIT_REPO_URI="git://github.com/heynemann/${PN}.git"
13         SRC_URI=""
14 else
15         SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
16 fi
17
18 DESCRIPTION="Generate Thumbor URLs from Python"
19 HOMEPAGE="https://github.com/thumbor/libthumbor https://pypi.python.org/pypi/libthumbor"
20
21 LICENSE="MIT"
22 SLOT="0"
23 KEYWORDS="~amd64 ~x86"
24 IUSE="test"
25
26 RDEPEND="
27         dev-python/six[${PYTHON_USEDEP}]
28         "
29
30 DEPEND="
31         test? (
32                 ${RDEPEND}
33                 dev-python/coverage[${PYTHON_USEDEP}]
34                 dev-python/flake8[${PYTHON_USEDEP}]
35                 dev-python/nose[${PYTHON_USEDEP}]
36                 dev-python/preggy[${PYTHON_USEDEP}]
37         )"
38
39 python_prepare_all() {
40         sed -i "s/packages=find_packages()/packages=find_packages(exclude=['tests', 'tests.*'])/" setup.py || die
41         distutils-r1_python_prepare_all
42 }
43
44 python_test() {
45         "${EPYTHON}" -c 'import coverage; coverage.main()' run --branch $(command -v nosetests) --nocapture tests ||
46                 die "tests failed with ${EPYTHON}"
47 }