Merge branch 'dev-python/pyssim'
[wtk-overlay.git] / dev-python / ipythonblocks / ipythonblocks-9999.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="5"
6 PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A built-package format for Python"
11 HOMEPAGE="https://github.com/jiffyclub/ipythonblocks/"
12 if [[ "${PV}" == "9999" ]]; then
13         inherit git-2
14         EGIT_BRANCH="master"
15         EGIT_REPO_URI="git://github.com/jiffyclub/${PN}.git"
16         SRC_URI=""
17 else
18         SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
19 fi
20
21 LICENSE="MIT"
22 SLOT="0"
23 KEYWORDS="~amd64 ~x86"
24 IUSE="examples test"
25
26 RDEPEND="${PYTHON_DEPS}
27         dev-python/ipython
28         test? ( >=dev-python/pytest-2.3 )
29         examples? ( dev-python/imaging )
30         "
31 DEPEND="${PYTHON_DEPS}"
32
33 src_install() {
34         distutils-r1_src_install
35         dodoc README.rst
36         if use examples; then
37                 dodoc -r demos
38         fi
39 }