Update URLs from einstein to tremily.
[wtk-overlay.git] / dev-python / FFT-tools / FFT-tools-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="4"
6 PYTHON_DEPEND="2:2.6"
7 SUPPORT_PYTHON_ABIS="1"
8 RESTRICT_PYTHON_ABIS="3.*"
9
10 inherit eutils distutils
11
12 if [[ ${PV} == "9999" ]] ; then
13         inherit git-2
14         EGIT_REPO_URI="git://tremily.us/${PN}.git"
15         SRC_URI=""
16 else
17         SRC_URI="http://git.tremily.us/?p=${PN}.git;a=snapshot;h=v${PV};sf=tgz"
18 fi
19
20 DESCRIPTION="Unitary FFTs and power spectra for real data"
21 HOMEPAGE="http://blog.tremily.us/posts/${PN}/"
22
23 LICENSE="GPL-3"
24 SLOT="0"
25 KEYWORDS="~x86 ~amd64"
26 IUSE="test"
27
28 src_unpack() {
29         if [[ ${PV} == "9999" ]] ; then
30                 git-2_src_unpack
31         else
32                 unpack ${A}
33         fi
34         cd "${S}"
35 }
36
37 src_install() {
38         distutils_src_install
39         dodoc README
40 }