34d5be0fe9a9e90f1984424ca52d162dca1dc5cf
[wtk-overlay.git] / dev-embedded / teensy-hid-listen / teensy-hid-listen-1.01.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="4"
6
7 inherit eutils
8
9 MY_PN="${PN//-/_}"
10 MY_PN="${MY_PN/teensy_}"
11 DESCRIPTION="Command line HID-raw listener for Teensy microcontrollers"
12 HOMEPAGE="http://pjrc.com/teensy/${MY_PN}.html"
13 SRC_URI="http://pjrc.com/teensy/${MY_PN}_${PV}.zip"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64"
18 IUSE=""
19
20 DEPEND="dev-libs/libusb"
21 RDEPEND="$DEPEND"
22
23 S="${WORKDIR}/${MY_PN}"
24
25 src_compile() {
26         emake OS=LINUX "CFLAGS=${CFLAGS}" "LDFLAGS=${LDFLAGS}" STRIP=echo
27 }
28
29 src_install() {
30         cp hid_listen teensy_hid_listen
31         dobin teensy_hid_listen
32 }