derpconf-9999.ebuild: Bump to EAPI 6 and git-r3
[wtk-overlay.git] / derpconf-9999.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=6
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit distutils-r1
9
10 if [[ "${PV}" == "9999" ]]; then
11         inherit git-r3
12         EGIT_REPO_URI="git://github.com/globocom/${PN}.git"
13         SRC_URI=""
14 else
15         SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
16 fi
17
18 DESCRIPTION="Abstracts configuration file loading"
19 HOMEPAGE="https://github.com/globocom/derpconf https://pypi.python.org/pypi/derpconf"
20
21 LICENSE="MIT"
22 SLOT="0"
23 KEYWORDS="~amd64 ~x86"
24 IUSE="test"
25
26 RDEPEND=""
27 DEPEND="
28         dev-python/six[${PYTHON_USEDEP}]
29         test? (
30                 dev-python/colorama[${PYTHON_USEDEP}]
31                 dev-python/coverage[${PYTHON_USEDEP}]
32                 dev-python/gevent[${PYTHON_USEDEP}]
33                 dev-python/pyvows[${PYTHON_USEDEP}]
34                 dev-python/tox[${PYTHON_USEDEP}]
35         )"
36
37 python_test() {
38         make test
39 }