rpmbuild: use --nodeps option
authorZac Medico <zmedico@gentoo.org>
Sun, 21 Jul 2013 16:53:32 +0000 (09:53 -0700)
committerZac Medico <zmedico@gentoo.org>
Sun, 21 Jul 2013 16:53:32 +0000 (09:53 -0700)
bin/misc-functions.sh

index ad99d8a320feb52ab1def38663e638d8776f122e..9375734cb944f98d6faaa1e150e4edbc65657f47 100755 (executable)
@@ -1231,7 +1231,7 @@ __dyn_rpm() {
        addwrite "${RPMDIR}"
        __dyn_spec
        HOME=${T} \
-       rpmbuild -bb --clean --rmsource "${PF}.spec" --buildroot "${D}" --target "${CHOST}" || die "Failed to integrate rpm spec file"
+       rpmbuild -bb --clean --nodeps --rmsource "${PF}.spec" --buildroot "${D}" --target "${CHOST}" || die "Failed to integrate rpm spec file"
        install -D "${dest_dir}/${PN}-${PV}-${PR}.${machine_name}.rpm" \
                "${RPMDIR}/${CATEGORY}/${PN}-${PV}-${PR}.rpm" || \
                die "Failed to move rpm"