Fix LIVEVCS.stable for -* keywords
authorAlec Warner <antarus@gentoo.org>
Sat, 10 Jun 2006 22:54:44 +0000 (22:54 -0000)
committerAlec Warner <antarus@gentoo.org>
Sat, 10 Jun 2006 22:54:44 +0000 (22:54 -0000)
svn path=/main/trunk/; revision=3487

bin/repoman

index b6808d1f9442862cd63526be2131f3eba3d486e8..4125aa972af9c9135eee872c787d478ae17e4037 100755 (executable)
@@ -1020,7 +1020,7 @@ for x in scanlist:
                not be allowed to be marked stable
                """
                if set(["darcs","cvs","subversion","git"]).intersection(myaux["INHERITED"].split()):
-                       bad_stable_keywords = [keyword for keyword in myaux["KEYWORDS"].split() if not keyword.startswith("~")]
+                       bad_stable_keywords = [keyword for keyword in myaux["KEYWORDS"].split() if not keyword.startswith("~") and not keyword.startswith("-")]
                        if bad_stable_keywords:
                                stats["LIVEVCS.stable"] += 1
                                fails["LIVEVCS.stable"].append(x+"/"+y+".ebuild with stable keywords:%s " % bad_stable_keywords)