Update workflow in README.dev from subversion to git
authorPaul Varner <fuzzyray@gentoo.org>
Thu, 6 Jan 2011 21:18:45 +0000 (15:18 -0600)
committerPaul Varner <fuzzyray@gentoo.org>
Thu, 6 Jan 2011 21:19:28 +0000 (15:19 -0600)
README.dev

index 84f7cf3b51154a276af14e75f7a12c4e7ad3aa6b..951b707df77174cac4485eaff9b7c91b0b3ff0c2 100644 (file)
@@ -17,23 +17,17 @@ Note: We are using VERSION="0.3.0" simply as an example.
 - Run Gentoolkit's test suite, make sure it passes:
 Note: requires dev-python/snakeoil
 
-Note: If running from the gentoolkit repository, please grab the eclean test file from:
-http://genscripts.googlecode.com/svn/trunk/gentoolkit/pym/gentoolkit/test/eclean/testdistfiles.tar.gz
-Please do not add/commit the test file to the gentoolkit repository
-
 ./setup.py test
 
-- Create a tag for the release
-svn copy svn+ssh://<dev>@svn.gentoo.org/var/svnroot/gentoolkit/trunk/gentoolkit \
-         svn+ssh://<dev>@svn.gentoo.org/var/svnroot/gentoolkit/tags/gentoolkit-0.3.0 \
-        -m "Tagging the <VERSION> release of gentoolkit."
-svn update to pull the tag from subversion
-cd to the local tags/gentoolkit-0.3.0 directory
-
 - Create a source distribution (you need to add VERSION here):
 VERSION="0.3.0" ./setup.py sdist
 Transfer dist/gentoolkit-0.3.0.tar.gz to dev.gentoo.org:/space/distfiles-local
 
 - Clean up temporary files:
 ./setup.py clean -a
+git status
+rm or mv any untracked files/directories
 
+- Create a tag for the release
+git tag gentoolkit-0.3.0
+git push origin gentoolkit-0.3.0