Fix UnicodeDecodeError in setup.py, bug 346001
authorfuzzyray <fuzzyray@gentoo.org>
Fri, 19 Nov 2010 20:18:46 +0000 (20:18 -0000)
committerfuzzyray <fuzzyray@gentoo.org>
Fri, 19 Nov 2010 20:18:46 +0000 (20:18 -0000)
svn path=/trunk/gentoolkit/; revision=858

setup.py

index 55cb3bd4df93c432096212a731e2ed0e2bd6927c..91f9e9c10817c5aeca5fe7bc8f662c35774835b6 100755 (executable)
--- a/setup.py
+++ b/setup.py
@@ -10,6 +10,7 @@ from distutils import core, log
 from glob import glob
 
 import os
+import io
 
 sys.path.insert(0, os.path.join(os.path.dirname(__file__), 'pym'))
 
@@ -59,13 +60,13 @@ class set_version(core.Command):
                def sub(files, pattern):
                        for f in files:
                                updated_file = []
-                               with open(f) as s:
+                               with io.open(f, 'r', 1, 'utf_8') as s:
                                        for line in s:
                                                newline = re.sub(pattern, '"%s"' % ver, line, 1)
                                                if newline != line:
                                                        log.info("%s: %s" % (f, newline))
                                                updated_file.append(newline)
-                               with open(f, 'w') as s:
+                               with io.open(f, 'w', 1, 'utf_8') as s:
                                        s.writelines(updated_file)
                quote = r'[\'"]{1}'
                bash_re = r'(?<=VERSION=)' + quote + '[^\'"]*' + quote