sci-calculators/units: Version 2.17.
authorJeroen Roovers <jer@gentoo.org>
Tue, 26 Jun 2018 19:20:30 +0000 (21:20 +0200)
committerJeroen Roovers <jer@gentoo.org>
Tue, 26 Jun 2018 19:21:00 +0000 (21:21 +0200)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

sci-calculators/units/Manifest
sci-calculators/units/files/units-2.17-network-sandbox.patch [new file with mode: 0644]
sci-calculators/units/units-2.17.ebuild [new file with mode: 0644]

index 54718b48ff6b9facc4ff0bbfd434d2cda97c99ff..1839e593f0dff5646e7792744022e0c9d4850e32 100644 (file)
@@ -1 +1,2 @@
 DIST units-2.16.tar.gz 1178197 BLAKE2B 6de569cd70c8067be053c5acb0885f898b76252bf6bafbea5f8b4972eca0acb13adfb4b2bc70ef0a3df747ee31084076fea3d3199922f0c44fc8c6d08232192b SHA512 afca2bf313208db2d0a3f4e96fed7bb86a3e96030b420e1cfa68a140499b9a8f2ef8c166c1d608d03c9ca6260199569a67c67c623d8c6a4b8d52e9d5cb6e3091
+DIST units-2.17.tar.gz 1185070 BLAKE2B 44db938b214596058cdfaeda7fd8d70161221c196a0971b5a0e03331e30fdeb52db85ab43b721f25efd755f4baee4f92aa6204a85d38703a31ec7cac0cefd689 SHA512 e4114f7dc0e40146f969375511c5d930497cb9502306ef82feac78c8e09a03e84ed0b582ff82e2878beae41702c9612f7a3d28fc6e9ed2cfae708f9feb8b737b
diff --git a/sci-calculators/units/files/units-2.17-network-sandbox.patch b/sci-calculators/units/files/units-2.17-network-sandbox.patch
new file mode 100644 (file)
index 0000000..e457610
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -107,7 +107,7 @@
+             -e "s@/usr/bin/python@$(PYTHON)@" \
+              $(srcdir)/units_cur > units_cur_inst
+-install-support: definitions.units units_cur_inst currency-units-update
++install-support: definitions.units units_cur_inst
+       $(MKDIR_P) $(DESTDIR)@UDAT@ $(DESTDIR)$(bindir) $(DESTDIR)@CDAT@
+       $(INSTALL_DATA) $(srcdir)/definitions.units $(DESTDIR)@UDAT@definitions.units
+       -rm -f $(DESTDIR)@UDAT@currency.units
diff --git a/sci-calculators/units/units-2.17.ebuild b/sci-calculators/units/units-2.17.ebuild
new file mode 100644 (file)
index 0000000..01fbb74
--- /dev/null
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit eutils python-single-r1
+
+DESCRIPTION="Unit conversion program"
+HOMEPAGE="https://www.gnu.org/software/units/units.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="FDL-1.3 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+units_cur"
+REQUIRED_USE="units_cur? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+       sys-libs/readline:=
+       units_cur? (
+               ${PYTHON_DEPS}
+               dev-python/future[${PYTHON_USEDEP}]
+               dev-python/requests[${PYTHON_USEDEP}]
+       )
+"
+DEPEND="
+       ${RDEPEND}
+"
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.17-network-sandbox.patch
+)
+
+pkg_setup() {
+       use units_cur && python-single-r1_pkg_setup
+}
+
+src_configure() {
+       econf \
+               --sharedstatedir="${EROOT}/var/lib" \
+               ac_cv_path_PYTHON=no
+}
+
+src_compile() {
+       emake ${PN}
+}
+
+src_install() {
+       emake DESTDIR="${D}" install
+
+       dodoc ChangeLog NEWS README
+
+       # we're intentionally delaying this since 'make install' would
+       # get confused if we shove 'units_cur' there, and there is no real
+       # need to add more complexity for it
+       if use units_cur; then
+               sed \
+                       -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
+                       -e 's|^#!|&/usr/bin/python|g' \
+                       units_cur_inst > units_cur || die
+               python_fix_shebang units_cur
+               python_doscript units_cur
+       fi
+}