app-eselect/eselect-lib-bin-symlink: Bump to EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Sun, 3 Nov 2019 14:12:44 +0000 (15:12 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 3 Nov 2019 14:32:02 +0000 (15:32 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-eselect/eselect-lib-bin-symlink/eselect-lib-bin-symlink-0.1.1-r1.ebuild [new file with mode: 0644]
app-eselect/eselect-lib-bin-symlink/eselect-lib-bin-symlink-9999.ebuild

diff --git a/app-eselect/eselect-lib-bin-symlink/eselect-lib-bin-symlink-0.1.1-r1.ebuild b/app-eselect/eselect-lib-bin-symlink/eselect-lib-bin-symlink-0.1.1-r1.ebuild
new file mode 100644 (file)
index 0000000..a8079a2
--- /dev/null
@@ -0,0 +1,15 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="An eselect library to manage executable symlinks"
+HOMEPAGE="https://github.com/mgorny/eselect-lib-bin-symlink/"
+SRC_URI="https://github.com/mgorny/eselect-lib-bin-symlink/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="app-admin/eselect"
index b98f185b49cdb0d8aef76ce44f5859379fd00e31..208e978f8a02dff4c9bedaa9fe9ad22d8f6d3daf 100644 (file)
@@ -1,10 +1,9 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 
-AUTOTOOLS_AUTORECONF=1
-inherit autotools-utils git-r3
+inherit autotools git-r3
 
 DESCRIPTION="An eselect library to manage executable symlinks"
 HOMEPAGE="https://github.com/mgorny/eselect-lib-bin-symlink/"
@@ -16,3 +15,8 @@ KEYWORDS=""
 IUSE=""
 
 RDEPEND="app-admin/eselect"
+
+src_prepare() {
+       default
+       eautoreconf
+}