games-mud/tkmoo: remove deprecated games eclass
authorAustin English <wizardedit@gentoo.org>
Fri, 5 Aug 2016 19:27:50 +0000 (14:27 -0500)
committerAustin English <wizardedit@gentoo.org>
Fri, 5 Aug 2016 19:43:17 +0000 (14:43 -0500)
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0

games-mud/tkmoo/files/0.3.32-Makefile-noclean.patch
games-mud/tkmoo/files/0.3.32-keys-workaround.patch
games-mud/tkmoo/tkmoo-0.3.32-r1.ebuild [new file with mode: 0644]

index c61a29df0ac8d8a29c0f9ad833db8d5b1922327e..cebc1fecfc347ca99e4674ce29d9fca31aeccca5 100644 (file)
@@ -1,5 +1,5 @@
---- Makefile.orig      2003-07-12 03:04:24.000000000 -0400
-+++ Makefile   2003-07-12 03:04:32.000000000 -0400
+--- a/Makefile 2003-07-12 03:04:24.000000000 -0400
++++ b/Makefile 2003-07-12 03:04:32.000000000 -0400
 @@ -32,11 +32,8 @@
  
  # some shells are set 'noclobber', so force overwriting of the
index d70e017f09e48a5df0980683b3505024323e740a..db8886ed4b6148181b52ec5712b924e7a42dd9fb 100644 (file)
@@ -1,5 +1,5 @@
---- source.tcl.orig    2004-12-28 23:36:47.000000000 -0800
-+++ source.tcl 2004-12-28 23:37:09.000000000 -0800
+--- a/source.tcl       2004-12-28 23:36:47.000000000 -0800
++++ b/source.tcl       2004-12-28 23:37:09.000000000 -0800
 @@ -51,6 +51,10 @@
  #
  #
diff --git a/games-mud/tkmoo/tkmoo-0.3.32-r1.ebuild b/games-mud/tkmoo/tkmoo-0.3.32-r1.ebuild
new file mode 100644 (file)
index 0000000..6664000
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+MY_PN=${PN/moo/MOO-light}
+MY_P=${P/moo/MOO-light}
+DESCRIPTION="MOO Client written in Tcl/Tk"
+HOMEPAGE="http://www.awns.com/tkMOO-light/"
+SRC_URI="http://www.awns.com/tkMOO-light/Source/${MY_P}.tar.gz"
+
+LICENSE="tkMOO"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="
+       >=dev-lang/tcl-8.3.3:0=
+       >=dev-lang/tk-8.3.3:0="
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+       "${FILESDIR}/${PV}-Makefile-noclean.patch"
+               "${FILESDIR}/${PV}-keys-workaround.patch"
+)
+
+src_compile() {
+       emake \
+               WISH="$(type -P wish)" \
+               TKMOO_LIB_DIR="/usr/$(get_libdir)/${MY_PN}" \
+               TKMOO_BIN_DIR=/usr/bin
+}
+
+src_install() {
+       emake \
+               TKMOO_LIB_DIR="${D}/usr/$(get_libdir)/${MY_PN}" \
+               TKMOO_BIN_DIR="${D}/usr/bin" \
+               install
+       dodoc README dot.tkmoolightrc bugsmail.txt
+       dosym tkMOO-lite /usr/bin/tkmoo
+       make_desktop_entry tkmoo "tkMOO"
+}