www-misc/wsmake: EAPI=7, add amd64, fix calling g++ directly
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Mon, 22 Apr 2019 09:04:31 +0000 (11:04 +0200)
committerDavid Seifert <soap@gentoo.org>
Tue, 23 Apr 2019 09:23:07 +0000 (11:23 +0200)
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com>
Signed-off-by: David Seifert <soap@gentoo.org>
www-misc/wsmake/wsmake-0.6.4-r1.ebuild [new file with mode: 0644]

diff --git a/www-misc/wsmake/wsmake-0.6.4-r1.ebuild b/www-misc/wsmake/wsmake-0.6.4-r1.ebuild
new file mode 100644 (file)
index 0000000..69070d3
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Website pre-processor features tag substitution and page ordering"
+HOMEPAGE="https://sourceforge.net/projects/wsmake/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ Artistic"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="examples"
+
+PATCHES=(
+       "${FILESDIR}"/${P}-bv.diff
+       "${FILESDIR}"/${P}-gcc43.patch  # 251745
+       "${FILESDIR}"/${P}-fix-const-va_list.patch
+)
+
+src_unpack() {
+       default
+
+       cd "${S}"/doc || die
+       tar -cf examples.tar examples || die
+}
+
+src_configure() {
+       tc-export CXX
+       default
+}
+
+src_install() {
+       default
+       dodoc doc/manual.txt
+
+       if use examples; then
+               rm -r doc/examples/CVS || die
+               dodoc -r doc/examples
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+}