net-dialup/freeradius: Apply patches earlier
authorMatt Turner <mattst88@gentoo.org>
Wed, 12 Feb 2020 00:16:04 +0000 (16:16 -0800)
committerMatt Turner <mattst88@gentoo.org>
Wed, 12 Feb 2020 00:25:40 +0000 (16:25 -0800)
src_prepare() selectively deletes subdirectories depending on USE flags
since configure.ac does not offer configurable switches. If a patch
applies changes to a directory that may be deleted, then src_prepare()
can fail depending on the USE flags that are set. This was the case with
USE=-python.

Avoid this possibility by applying patches before deleting directories.

Signed-off-by: Matt Turner <mattst88@gentoo.org>
net-dialup/freeradius/freeradius-3.0.20.ebuild

index 533b388bf6c2c4166736af40d85ec6504fd0aa4d..5d43f28c636d95ad16b2b0ec32bae650d439d60e 100644 (file)
@@ -90,6 +90,7 @@ src_prepare() {
        # not interested in using.
 
        eapply_user
+       default
 
        use ssl || { rm -r src/modules/rlm_eap/types/rlm_eap_{tls,ttls,peap} || die ; }
        use ldap || { rm -r src/modules/rlm_ldap || die ; }
@@ -158,8 +159,6 @@ src_prepare() {
        usesqldriver sqlite
        usesqldriver mongodb mongo
 
-       default
-
        eautoreconf
 }