x11-terms/kitty-terminfo: bump to 0.17.3
authorend222 <pabloorduna98@gmail.com>
Sun, 26 Apr 2020 09:50:47 +0000 (11:50 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 26 Apr 2020 13:36:51 +0000 (16:36 +0300)
Signed-off-by: Pablo Orduna <pabloorduna98@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/15521
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
x11-terms/kitty-terminfo/Manifest
x11-terms/kitty-terminfo/kitty-terminfo-0.17.3.ebuild [new file with mode: 0644]

index 15b7b5f10e3a2f4c857e59cbfec1a827431260cc..e958c1af17e353c436588db3ab57ee3f4011aeda 100644 (file)
@@ -1,2 +1,3 @@
 DIST kitty-0.16.0.tar.xz 2974592 BLAKE2B 971e279cd24369a454495fc7a236356e6a4ee69a0953563a9283a16e21bd67ddea5ab8f795c75be6cd31d05c5f1b39b1525e957b9bcd59d12ea3e701b21aa59c SHA512 24dedfc58c5d33aa18da85f904952129f39cd54afb70282c7572b57514b1deebfb532414913e0efc3a5c0352a81406cd7ddef99490dbd9186dc61eab7af3975b
 DIST kitty-0.17.2.tar.xz 3044140 BLAKE2B 12dcb8ddb7d90a22904f575301e8c2b1672c3212ee29a035fa5e8eec553dafb0e2c8c1cc3a491c8ac6854d619e979e518d83c5218f36647a032a4f847d068ef3 SHA512 bccf1c1d60d1149bc5f849b82db1af80a2d9a7a11c5f2df853daae5700550eef98da389a30f015d67be796f39deacb31f3ee245eb37ba1a41ba377c70cd26d61
+DIST kitty-0.17.3.tar.xz 3064216 BLAKE2B f5ab532d97c211ceed463c24758635a9e7168bf03990889a98ebdad7fc8c1c60f5f3726724007f00ac6a5f5e8db44ca54a4a43027dbf6ce1fdfcaa40c7b8e10c SHA512 dc14ba35e77e0ebd1978fde0731b00e726e75137f900952dfa6b06add1f46e3a3f42e8e886ce8c689e4e3500f2d2216a66225d5211522a41d09ef61265065e2d
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.17.3.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.17.3.ebuild
new file mode 100644 (file)
index 0000000..b37c1bb
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-any-r1 toolchain-funcs xdg
+
+DESCRIPTION="Terminfo for kitty, an OpenGL-based terminal emulator"
+HOMEPAGE="https://github.com/kovidgoyal/kitty"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="${PYTHON_DEPS}"
+
+PATCHES=(
+       "${FILESDIR}"/kitty-terminfo-setup-0.17.2.patch
+)
+
+# kitty-terminfo is a split package from kitty that only installs the terminfo
+# file. As tests are designed to be run with the whole package compiled they
+# would fail in this case.
+RESTRICT="test"
+
+src_compile() {
+       "${EPYTHON}" setup.py \
+               --verbose $(usex debug --debug "") \
+               --libdir-name $(get_libdir) \
+               linux-terminfo || die "Failed to compile kitty."
+}
+
+src_install() {
+       insinto /usr
+       doins -r linux-package/*
+}