net-dialup/xl2tpd: bump version to 1.3.13, readd kernel mode
authorTorsten Alex <tee@itc-gmbh.de>
Sun, 17 Feb 2019 03:41:12 +0000 (04:41 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 19 Apr 2019 14:10:14 +0000 (16:10 +0200)
Closes: https://bugs.gentoo.org/677678
Signed-off-by: Torsten Alex <tee@itc-gmbh.de>
Package-Manager: Portage-2.3.51, Repoman-2.3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-dialup/xl2tpd/Manifest
net-dialup/xl2tpd/metadata.xml
net-dialup/xl2tpd/xl2tpd-1.3.13.ebuild [new file with mode: 0644]

index e9deade53323d1ae39dbd003d318a2cd7bb6fb15..be0431697f76dcc9565c273c971e6e616b0a4994 100644 (file)
@@ -1,4 +1,5 @@
 DIST xl2tpd-1.3.10.tar.gz 510777 BLAKE2B 15ec09a6186d20facd4eceeca87a33a4676644a6976c2b69a61b288a2534c354bcc9b64eca4305aa7774d3b5fc29c97078478bebec7e81f8071865b29a97809e SHA512 304b8cd098608a866d32c65c55ba98a01e10abb473d8bff488c723fd1f6d4a66cf98c6d3044f7986a334739693767608c48999f873e95a51f0fa6c23cb61ecd4
 DIST xl2tpd-1.3.11.tar.gz 510652 BLAKE2B c120ba0a2bb96a87334743319808e4a1dfb1b95140fc37df51c33e176bdefdac547ad27d38731bab9d94a939b9a3ca93404ef17c8076e16567a3ecc5b568fb47 SHA512 9fd478aa6b7e22867aa977aa0c22ba9d856e3b659aa0ffdcdb17aa0d8358cceab37da565eeb799590d65fc2914720715423e006f6bbe7ca742f09d7cced52cb7
 DIST xl2tpd-1.3.12.tar.gz 513173 BLAKE2B a1f2e4d0e1af4402679eeec6589ca17b0422c664d37beae628511f988f6508ca22160d4657f8ff84bc5e5aac4d3e837c501b4d307964530044a792f2ecc599ab SHA512 e18f15ba038cd358fbad9dd7284c5f3c34273d9291bf8c66494c46d78150acfc1666cbf935fb5a66bd1f0220014f0b49fa0f7f55cb42de125e4123112c6eb00b
+DIST xl2tpd-1.3.13.tar.gz 513958 BLAKE2B 66c2bcbb54191445f1a519d507b2ec67b48d9e994db09b8c6fc9980b03bf5aab09a2f6187170f0e8639bd8a323b8417bf6e5d0a80fd9e45f8adc310902b256ae SHA512 02e3502a75f41745c001fe1a34dd9900c3a77eea274e08f9361f7145ac24e9a663975efe85ef6aef7c6da1aa9f3369eeb5542ac26e90b9d59753158a17b69ee4
 DIST xl2tpd-1.3.6.tar.gz 553981 BLAKE2B 3e79534fe3eaa906cf09da93b7f6be2931e4c7fc8ff43dd9683ae846e1e2351c3bee81ac8853dee6c7e45ad8b60f8727edbd95d6dd30cc508288227b09da351c SHA512 868c65660e6a45fb8dc22b95542e9d6ca0dc8e5033cc9df04171a651ef273bc5d711a85f61d4a971d714089f7a10ee67460d8ab9f3c007fcffe0e11e81ae0bfd
index 3da1a1ee38248f21f1e609dc2e66575d697a07a8..8066f7a44b9ecc3f6484c67ef057528285a5cc7b 100644 (file)
@@ -12,6 +12,7 @@
        <longdescription>xl2tpd is a fork of l2tpd Layer 2 Tunneling Protocol (L2TP) daemon that can be used to transfer frames of OSI layer 2 protocols through an IP tunnel. While it provides authentication via CHAP or PAP it does not provide encryption itself and should therefore be externally secured (via IPSEC).</longdescription>
        <use>
                <flag name="dnsretry">Patch for host lookup retries, activated by redial feature</flag>
+               <flag name="kernel">Enable kernel interface for PPPoL2TP</flag>
        </use>
        <upstream>
                <remote-id type="github">xelerance/xl2tpd</remote-id>
diff --git a/net-dialup/xl2tpd/xl2tpd-1.3.13.ebuild b/net-dialup/xl2tpd/xl2tpd-1.3.13.ebuild
new file mode 100644 (file)
index 0000000..ff05839
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="A modern version of the Layer 2 Tunneling Protocol (L2TP) daemon"
+HOMEPAGE="https://github.com/xelerance/xl2tpd"
+SRC_URI="https://github.com/xelerance/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="+kernel"
+
+DEPEND="
+       net-libs/libpcap
+       >=sys-kernel/linux-headers-2.6"
+
+RDEPEND="
+       ${DEPEND}
+       net-dialup/ppp"
+
+DOCS=(CREDITS README.xl2tpd BUGS CHANGES TODO doc/README.patents)
+
+src_compile() {
+       tc-export CC
+       local OSFLAGS="-DLINUX"
+       use kernel && OSFLAGS+=" -DUSE_KERNEL"
+       emake OSFLAGS="$OSFLAGS"
+}
+
+src_install() {
+       emake PREFIX=/usr DESTDIR="${D}" install
+
+       newinitd "${FILESDIR}"/xl2tpd-init-r1 xl2tpd
+
+       systemd_dounit "${FILESDIR}"/xl2tpd.service
+       systemd_dotmpfilesd "${FILESDIR}"/xl2tpd.conf
+
+       einstalldocs
+
+       insinto /etc/xl2tpd
+       newins doc/l2tpd.conf.sample xl2tpd.conf
+       insopts -m 0600
+       newins doc/l2tp-secrets.sample l2tp-secrets
+}