app-crypt/certbot-apache: 0.18.0 bup
authorMatthew Thode <prometheanfire@gentoo.org>
Thu, 7 Sep 2017 21:16:59 +0000 (16:16 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Thu, 7 Sep 2017 21:18:37 +0000 (16:18 -0500)
Package-Manager: Portage-2.3.6, Repoman-2.3.3

app-crypt/certbot-apache/Manifest
app-crypt/certbot-apache/certbot-apache-0.18.0.ebuild [new file with mode: 0644]

index 8a5e0817e457da5fbc41cdf9a9db8d0078f21b65..3633d051e09359d2faa38c2eb2eb63b8593537a5 100644 (file)
@@ -1,2 +1,3 @@
 DIST certbot-0.15.0.tar.gz 942788 SHA256 87d306b1c013b472b8f548b38ccc476c125816435bb3b99e932fed09ac777296 SHA512 e884b34985a1128ce94d6b2be77af6ee86ded8b870e066f3f4bc22f78501f3f0a51060edcf75a11cd31dd525388adb8ccc4e2da0068b5b75be131d0fb0ca6844 WHIRLPOOL 01b172e8c7ac5d3678ee608b36d93f23943bf17f1e9c593cc1af3febcf0549b03961e69e537f099643dd9ee268497f76c2c18d8fa7a1d45753bc50e670375317
 DIST certbot-0.17.0.tar.gz 1036099 SHA256 ed4334dce166bf38ecc7218449efda3798d62c7e2934a71702c0dc3d78eccdd1 SHA512 57fa830d19173eacdbb17242a3c446d9414f02e09fab6ccd41c82b15156bc103ec358ff3d515e94881fcf6438f6acfe449eee9bb3108df41f7b8f2395500b549 WHIRLPOOL cbfffc3866ffed3e0c702ac686768e879c7f1306a62dc050aab05e5a207b4f77a4acae9ca8f3ce973a6691d98838a488ab6335aa0692dd2b28a99c8aecff232d
+DIST certbot-0.18.0.tar.gz 1043633 SHA256 e7ec8c07fadac378d6f54c8e789aa462fdee6333b71ca7b47b892fcfa03dc858 SHA512 85061e9311a4be7acfac4a804fd43939802938b5c241881fd4db870f803d821bac97acc365c940b616fa212cb51758fa78ba74687768b82c733778f7342d9a9d WHIRLPOOL 748a7ff05563179eaaa14f8c27dd89983029f1af03a8051a1832ce0fe1d66911ceabd3804a23e9f4468064a0876e7a698cc1edfbfe2b4e3993130b7c5f089783
diff --git a/app-crypt/certbot-apache/certbot-apache-0.18.0.ebuild b/app-crypt/certbot-apache/certbot-apache-0.18.0.ebuild
new file mode 100644 (file)
index 0000000..93bc955
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+if [[ ${PV} == 9999* ]]; then
+       EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+       inherit git-r3
+       S=${WORKDIR}/${P}/${PN}
+else
+       SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
+       KEYWORDS="~amd64"
+       S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="~app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+       ~app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+       dev-python/mock[${PYTHON_USEDEP}]
+       dev-python/python-augeas[${PYTHON_USEDEP}]
+       dev-python/zope-component[${PYTHON_USEDEP}]
+       dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+       dev-python/nose[${PYTHON_USEDEP}] )
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+       nosetests || die
+}