app-laptop/batti: Remove last-rited package
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 29 May 2020 19:44:18 +0000 (21:44 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 29 May 2020 22:11:34 +0000 (00:11 +0200)
Closes: https://bugs.gentoo.org/708114
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-laptop/batti/Manifest [deleted file]
app-laptop/batti/batti-0.3.8-r4.ebuild [deleted file]
app-laptop/batti/files/batti-0.3.8-upower-0.99.patch [deleted file]
app-laptop/batti/files/batti-0.3.8-upower-capital.patch [deleted file]
app-laptop/batti/metadata.xml [deleted file]
profiles/package.mask

diff --git a/app-laptop/batti/Manifest b/app-laptop/batti/Manifest
deleted file mode 100644 (file)
index 683411c..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST batti-0.3.8.tar.gz 59783 BLAKE2B cba35af1d8d3e5f2e44e27eb2727fc2115d89d5ff79bd54f263a25678c4a5d9d87da685905f85c3d47bdeeeba164bb0dce09082adb211acc51a02ec514e0122a SHA512 39e0085a13847359eb555eff80c3f3b166775558fba3c76ecb4315786e2ce4307d21dcac5fab38da4ee3cc2035356906eb1354ced56a1f007735029e0484a4de
diff --git a/app-laptop/batti/batti-0.3.8-r4.ebuild b/app-laptop/batti/batti-0.3.8-r4.ebuild
deleted file mode 100644 (file)
index 2b16979..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 gnome2-utils
-
-DESCRIPTION="A upower based battery monitor for the system tray, similar to batterymon"
-HOMEPAGE="https://code.google.com/p/batti-gtk/"
-SRC_URI="https://batti-gtk.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="libnotify"
-
-RDEPEND="
-       dev-python/pygtk:2[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
-       sys-power/upower
-       x11-themes/hicolor-icon-theme
-       libnotify? ( x11-libs/libnotify )
-"
-DEPEND=""
-
-src_prepare() {
-       default
-       if has_version ">=sys-power/upower-0.99"; then
-               eapply "${FILESDIR}/${P}-upower-0.99.patch"
-               eapply "${FILESDIR}/${P}-upower-capital.patch"
-       fi
-}
-
-pkg_preinst() {
-       gnome2_icon_savelist
-}
-
-pkg_postinst() {
-       gnome2_icon_cache_update
-}
-
-pkg_postrm() {
-       gnome2_icon_cache_update
-}
diff --git a/app-laptop/batti/files/batti-0.3.8-upower-0.99.patch b/app-laptop/batti/files/batti-0.3.8-upower-0.99.patch
deleted file mode 100644 (file)
index 6f313a5..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-diff -Naur batti-0.3.8.orig/src/PowerBackend.py batti-0.3.8/src/PowerBackend.py
---- batti-0.3.8.orig/src/PowerBackend.py       2014-04-15 19:30:34.123260000 +0200
-+++ batti-0.3.8/src/PowerBackend.py    2014-04-15 19:32:11.859168509 +0200
-@@ -180,17 +180,6 @@
-         
-         properties = dbus.Interface(iface, 'org.freedesktop.DBus.Properties')
--        if properties.Get(self.dbus_interface, 'CanSuspend'):
--            self.__can_suspend = True
--        else:
--            self.__can_suspend = False
--        
--        if properties.Get(self.dbus_interface, 'CanHibernate'):
--            self.__can_hibernate = True
--        else:
--            self.__can_hibernate = False
--    
--    
-     def __get_interface(self):
-         dkit_obj = self.__bus.get_object(self.dbus_service, self.dbus_object)
-         return dbus.Interface(dkit_obj, self.dbus_interface)
-@@ -201,12 +190,6 @@
-             self.__mc_action(widget, event, data)
-             
-          
--    def can_suspend(self):   
--        return self.__can_suspend and self.__get_interface().SuspendAllowed()
--
--    def can_hibernate(self):
--        return self.__can_hibernate and self.__get_interface().HibernateAllowed()
--
-     def suspend(self):
-         self.__get_interface().Suspend()
diff --git a/app-laptop/batti/files/batti-0.3.8-upower-capital.patch b/app-laptop/batti/files/batti-0.3.8-upower-capital.patch
deleted file mode 100644 (file)
index e7f6276..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-From 1e0fe57a93ed3996bad295e20eeda81f6af483af Mon Sep 17 00:00:00 2001
-From: Christian Ruppert <idl0r@gentoo.org>
-Date: Wed, 20 Jul 2016 20:14:32 +0200
-Subject: [PATCH] The type property (in recent UPower at least) needs to have a
- capital T - "Type"
-
----
- src/PowerBackend.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/PowerBackend.py b/src/PowerBackend.py
-index e020b98..56bcb61 100644
---- a/src/PowerBackend.py
-+++ b/src/PowerBackend.py
-@@ -165,7 +165,7 @@ def __init__(self):
-         self.__batteries = {}
-         for dev in devices:
-             (prop_iface, dev_iface) = self.__get_battery(dev)
--            type = prop_iface.Get(self.device_interface, 'type')
-+            type = prop_iface.Get(self.device_interface, 'Type')
-             if type == self.bat_type:
-                 power_bat = UPowerBattery(prop_iface, dev_iface)
-                 self.__batteries[dev] = power_bat
-@@ -228,7 +228,7 @@ def set_right_popup_menu_action(self, action):
-     def __device_added(self, udi):
-         (prop_iface, dev_iface) = self.__get_battery(udi)
-         try:
--            type = prop_iface.Get(self.device_interface, 'type')
-+            type = prop_iface.Get(self.device_interface, 'Type')
-             if type == self.bat_type:
-                 power_bat = UPowerBattery(prop_iface, dev_iface)
-                 power_bat.set_left_popup_menu_action(self.__mc_action)
diff --git a/app-laptop/batti/metadata.xml b/app-laptop/batti/metadata.xml
deleted file mode 100644 (file)
index c26d102..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-       <maintainer type="person">
-               <email>naota@gentoo.org</email>
-               <name>Naohiro Aota</name>
-       </maintainer>
-       <upstream>
-               <remote-id type="google-code">batti-gtk</remote-id>
-       </upstream>
-</pkgmetadata>
index 2c183bb6b875b1c37fd261a78ee7bd640dcf7c8c..9cb977224efa7b7ab73b0cd7abd7d1192315a2f4 100644 (file)
@@ -224,11 +224,6 @@ dev-embedded/pk2-la
 # Stuck on Python 2 and pygtk. Masked for removal in 30 days.
 app-misc/metromap
 
-# Andreas Sturmlechner <asturm@gentoo.org> (2020-04-30)
-# Maintainer timeout, unmaintained upstream, last release in 2011, bug #708114
-# Stuck on Python 2 and pygtk. Masked for removal in 30 days.
-app-laptop/batti
-
 # Matt Turner <mattst88@gentoo.org> (2020-04-29)
 # Masked for testing
 >=dev-libs/gjs-1.64