dev-java/swt: add openjdk11 libjawt.so path
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Sat, 25 Apr 2020 09:34:55 +0000 (02:34 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Sat, 25 Apr 2020 09:35:17 +0000 (02:35 -0700)
Closes: https://bugs.gentoo.org/689976
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-java/swt/swt-4.10.ebuild

index f7fa9be7233a8ed50c25c8763c5fb0197cffb182..4559e6bb888cea5fe79ea5d7bebd77719f6eabf9 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -96,6 +96,8 @@ src_compile() {
                export AWT_LIB_PATH="${JAVA_HOME}/jre/bin"
        elif [[ -f "${JAVA_HOME}/$(get_libdir)/${JAWTSO}" ]] ; then
                export AWT_LIB_PATH="${JAVA_HOME}/$(get_libdir)"
+       elif [[ -f "${JAVA_HOME}/lib/${JAWTSO}" ]] ; then
+               export AWT_LIB_PATH="${JAVA_HOME}/lib"
        else
                eerror "${JAWTSO} not found in the JDK being used for compilation!"
                die "cannot build AWT library"