app-backup/borgbackup: remove older version
authorAnthony G. Basile <blueness@gentoo.org>
Thu, 23 Apr 2020 18:39:30 +0000 (14:39 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Thu, 23 Apr 2020 18:51:09 +0000 (14:51 -0400)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
app-backup/borgbackup/borgbackup-1.1.11-r1.ebuild [deleted file]

diff --git a/app-backup/borgbackup/borgbackup-1.1.11-r1.ebuild b/app-backup/borgbackup/borgbackup-1.1.11-r1.ebuild
deleted file mode 100644 (file)
index 822bb8b..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]] ; then
-       EGIT_REPO_URI="https://github.com/${PN}/borg.git"
-       inherit git-r3
-else
-       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-       KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Deduplicating backup program with compression and authenticated encryption"
-HOMEPAGE="https://borgbackup.readthedocs.io/"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="libressl"
-
-# Unfortunately we have a file conflict with app-office/borg, bug #580402
-RDEPEND="
-       !!app-office/borg
-       app-arch/lz4
-       virtual/acl
-       dev-python/llfuse[${PYTHON_USEDEP}]
-       ~dev-python/msgpack-0.5.6[${PYTHON_USEDEP}]
-       dev-python/pyzmq[${PYTHON_USEDEP}]
-       !libressl? ( dev-libs/openssl:0= )
-       libressl? ( dev-libs/libressl:0= )
-"
-
-DEPEND="
-       dev-python/setuptools_scm[${PYTHON_USEDEP}]
-       dev-python/cython[${PYTHON_USEDEP}]
-       ${RDEPEND}
-"
-
-python_prepare_all() {
-       rm -rf src/borg/algorithms/msgpack
-       eapply "${FILESDIR}"/${P}-unbundle-msgpack.patch
-       distutils-r1_python_prepare_all
-}
-
-src_install() {
-       distutils-r1_src_install
-       doman docs/man/*
-}