app-mobilephone/wammu: Test LINGUAS rather than linguas_* USE flags.
authorUlrich Müller <ulm@gentoo.org>
Sat, 6 Jan 2018 23:26:34 +0000 (00:26 +0100)
committerUlrich Müller <ulm@gentoo.org>
Sat, 6 Jan 2018 23:27:44 +0000 (00:27 +0100)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

app-mobilephone/wammu/wammu-0.40.ebuild
app-mobilephone/wammu/wammu-0.43.ebuild

index 9b7861ba00af8e8230a9ef59c008c5bd03ea18ad..320c41fab71304297386c4056f0ec4b092abacd9 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -25,29 +25,18 @@ RDEPEND="|| ( ( >=app-mobilephone/gammu-1.36 dev-python/python-gammu )
 DEPEND="${RDEPEND}"
 
 # Supported languages and translated documentation
-# Be sure all languages are prefixed with a single space!
 MY_AVAILABLE_LINGUAS=" af ar bg bn ca cs da de el en_GB es et fi fr gl he hu id it ko nl pl pt_BR ro ru sk sv sw tr uk zh_CN zh_TW"
-IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
 
 # Required to source locale content out of the box
 DISTUTILS_IN_SOURCE_BUILD=1
 
 src_prepare() {
-       local lang support_linguas=no
+       local lang
        for lang in ${MY_AVAILABLE_LINGUAS} ; do
-               if use linguas_${lang} ; then
-                       support_linguas=yes
-                       break
+               if ! has ${lang} ${LINGUAS-${lang}} ; then
+                       rm -r locale/${lang} || die
                fi
        done
-       # install all languages when all selected LINGUAS aren't supported
-       if [ "${support_linguas}" = "yes" ]; then
-               for lang in ${MY_AVAILABLE_LINGUAS} ; do
-                       if ! use linguas_${lang} ; then
-                               rm -r locale/${lang} || die
-                       fi
-               done
-       fi
 
        distutils-r1_src_prepare
 }
index d13beae0c76312165574b84589503f69d74ef5ad..dd959761aaeeb62bab90b0a6b230451d388a061e 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -27,29 +27,18 @@ RDEPEND="
 DEPEND="${RDEPEND}"
 
 # Supported languages and translated documentation
-# Be sure all languages are prefixed with a single space!
 MY_AVAILABLE_LINGUAS=" af ar bg bn ca cs da de el en_GB es et fi fr gl he hu id it ko nl pl pt_BR ro ru sk sv sw tr uk zh_CN zh_TW"
-IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
 
 # Required to source locale content out of the box
 DISTUTILS_IN_SOURCE_BUILD=1
 
 src_prepare() {
-       local lang support_linguas=no
+       local lang
        for lang in ${MY_AVAILABLE_LINGUAS} ; do
-               if use linguas_${lang} ; then
-                       support_linguas=yes
-                       break
+               if ! has ${lang} ${LINGUAS-${lang}} ; then
+                       rm -r locale/${lang} || die
                fi
        done
-       # install all languages when all selected LINGUAS aren't supported
-       if [ "${support_linguas}" = "yes" ]; then
-               for lang in ${MY_AVAILABLE_LINGUAS} ; do
-                       if ! use linguas_${lang} ; then
-                               rm -r locale/${lang} || die
-                       fi
-               done
-       fi
 
        distutils-r1_src_prepare
 }